Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried killing Firefox 3.5 from OSX command line using "kill -9 pid", and the process was still running

mini-2:~ prompt$ ps -ef | grep firefox

501 15087 183 0 0:00.00 ?? 0:00.00 (firefox-bin)

After this, I could not start firefox (as it said Firefox is already running) nor can I kill firefox (again).

What is going on? How can I fix this (besides logging of or restarting my machine) ?

share|improve this question
up vote 1 down vote accepted

Possibly you have a 'stuck' process. If you run top, the first line will list if there is anything stuck. Likewise, if you run ps auxww, the eighth field will be a 'U' if something is stuck. (I learned about stuck processes when I couldn't reboot a server.)

share|improve this answer
run ps auxww: mini-2:~ lydonchandra$ ps auxww | grep firefox lydonchandra 15087 0.0 0.0 0 0 ?? E Sat07pm 0:00.00 (firefox-bin ) the eight field is 'E' rather than 'U'. So how did you unstick the stuck process? – portoalet May 18 '10 at 17:43
@lydonchandra I had to shut down my machine hard :( . It looks like 'E' indicates a program is exiting, and that you'll have to reboot. See… – Clinton Blackmore May 18 '10 at 17:59

Have you tried force quitting it? Command-Option-Escape

share|improve this answer
yes I tried that, and it didn't work. Now the firefox icon is nowhere to be seen. – portoalet May 18 '10 at 17:15
This is really a comment, not an answer to the question. Please use "add comment" to leave feedback for the author. – Diogo Aug 9 '12 at 14:33

Does a process still show in Activity Monitor? You should be able to find the Firefox process running there and kill the process or any parent processes that might be using it (Java or Flash for example may be causing a hang).

share|improve this answer
No the process is not listed in Activity Monitor. – portoalet May 18 '10 at 17:22
That is extremely perplexing. Have you changed the view setting to see all running processes via the drop down option? If it truly is not there then I am REALLY stumped since as far as I've ever experienced every running processes is listed there. I'll keep an eye on this one then and hope for an answer as well. – Insomnic May 18 '10 at 19:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .