Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I'm using remote desktop to connect to my PC from my laptop(both running Windows 7 ultimate), RDPClip.exe never gets started. I can run it manually and copy/paste will work just fine, but I have no idea why it won't start automatically.

I've done the usual of making sure the "Drives" checkbox is checked, but other than that I have no idea why it's mad.

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted
+100

Ensure that you're using the latest Remote Desktop Connection 7.0 client update.
Even if you're using the latest version, re-installing the RDP client and rebooting might help.

Verify that rdpclip.exe is in its right place : C:\Windows\System32\rdpclip.exe.

Also verify that the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\rdpwd contains the right entry for StartupPrograms. It should contain "rdpclip", but you can also try the full path "C:\Windows\System32\rdpclip.exe".

The last-ditch solution, used when no better one is found, is to use a .bat file that contains:

Taskkill.exe /im rdpclip.exe
Rdpclip.exe

Some people even added this script as a startup item, and report that this solved the problem (after reboot).

share|improve this answer
    
Thanks for this. For some reason the registry entry for StartupPrograms had no value in it. That fixed it! –  Ross Jun 10 '10 at 22:29
    
Unfortunately it seems that this doesn't fix it in all cases. In my computer everything is fine (also checked this social.technet.microsoft.com/Forums/is/winserverTS/thread/…) and still cant set it up to start automatically. If I start rpdclip manually everything is fine. –  Odys Feb 22 '13 at 10:07
    
@Odys: I need more info on your computer, so possibly you could start a post of your own with info such as OS and patch-level. Just to remark that if you installed optional Windows Update 2592687 (RDP 8), I had troubles with it and had to uninstall it. –  harrymc Feb 22 '13 at 10:54
    
@harrymc Thanks for replying. That helped a lot. –  Odys Feb 22 '13 at 13:21
add comment

That's weird. :)

One place to check is the registry key (on the machine you are trying to RDP TO) HKey_Local_Machine\SYSTEM\CurrentControlSet\Control\Terminal Server\Winstations\RDP-Tcp\fDisableClip

Ensure it's set to 0 -- If fDisableClip is set to 1 then rdpclip.exe won't run.

share|improve this answer
    
Thanks for replying, I checked this and it's already set to 0. –  Ross May 18 '10 at 22:28
add comment

On the remote desktop client click the options button and go to local resources and make sure that the clipboard option is checked before initiating the connection.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.