Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a new Lenovo T500, with Ubuntu 8.04 LTS installed.

The wireless card isn't working - sometimes it detects the wireless networks, but most of the times it can't. I have tried using the network icon, but it still can't find any network.

lspci yielded this:

03:00.0 Network controller: Intel Corporation Unknown device 4237

Googling it didn't help much. Any Ideas?

EDIT: I'm having trouble installing the Intel Linux Wireless from the wlwifi project. Any help would be deeply appreciated.

Thanks,

Udi

share|improve this question
    
BTW any idea what the model of your network card is? – Ivo Flipse Jul 28 '09 at 8:12
    
Intel AGN 5100. – Adam Matan Jul 28 '09 at 8:45
    
Glad it worked for you! – Ivo Flipse Aug 6 '09 at 7:20
up vote 5 down vote accepted
+100

Install different drivers, that support it better.

Perhaps look at Intel Linux Wireless for the drivers you need


Or try a different network connection manager like Wicd

Wicd is an open source wired and wireless network manager for Linux which aims to provide a simple interface to connect to networks with a wide variety of settings.

alt text

share|improve this answer
    
I'll try the second option - the lspci insinuates it is a driver, not connection manager, problem. Thanks! – Adam Matan Jul 28 '09 at 8:08
    
I switched it around if that's the most likely correct answer – Ivo Flipse Jul 28 '09 at 8:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .