Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My setup is as follows:- Main ADSL modem / router (switch) configured as DHCP server with address range 192.168.0.25-60 The office machines are configured with fixed IP ( not in the same address pool of course ) and hard wired to this router. A wireless access point ( Router ) is connected to provide Internet access for guests in a separate area. This router is NOT configured as a DHCP server. Wireless authentication is turned off. IP address lease times are set to 4 hours. Sometimes guests are able to connect to the wireless access point but they are not given a valid IP. They get 169.x.x.x addresses. Rebooting their machines does not resolve the problem. The only way to resolve is to reboot the main ADSL/router which is often frustrating for other users who are successfully connected with valid IP and DG. The problem seems to occur more frequently to Apple/Mac guests although it also sometimes occurs with Win machines. I personally use Ubuntu on my Laptop and thus far, never have had any problem connecting and getting a valid IP address in the guest area. One further point of note which may give a clue is that certain guests ( always Apple/Mac ) get lease times of 90 days. However, this does not 'stack out' the number of available addresses and of course, rebooting the router clears them until the next time they login.

share|improve this question
4  
169.x.x.x addresses are not handed out by the DHCP server. The computer automatically selects a 169.x.x.x address if it is not able to obtain in IP via DHCP, so you are not getting an IP via DHCP. –  heavyd May 19 '10 at 5:09

3 Answers 3

The 169.x.x.x addresses are so called "link-local" addresses (see: link-local addresses @ wikipedia). They are usually assigned by the OS when the DHCP server won't give out a valid address or there's no DHCP server at all.

Are you sure the amount of dynamic addresse is high enough and the lease time is small enough?

share|improve this answer
    
Yes quite sure. There are 35 IP addresses in the pool with a maximum of 10 in use including 'redundant' ones. ( Users who have left yet their IP shows in use. ) lease time of 4 hours should be optimum . Thx –  user37615 May 19 '10 at 5:13

Does your configuration look like this

MainRtr---WIFIRtr

With the WIFI's WAN/Internet port being connected to MainRtr?

share|improve this answer
    
If I understand you correctly, you are asking if my WiFi Router access point is connected to the main router via its WAN socket as opposed to a LAN socket - if so , then the answer is definitely not. I did check though , just in case –  user37615 May 20 '10 at 0:38
    
That means that the LAN ports of both devices are in the same collision domain as well as the WIFI clients, unless you have some ports configured as VLANS. If not they all need to be on the same network. I think that is what you have, with just one DHCP server, just checking. –  dbasnett May 20 '10 at 17:56
    
I don't know what you mean by a 'collision domain'.Nor what is meant by a VLAN. I would confirm that All the devices are in the same network subnet 192.168.0.xx.The WiFi devices are on a fixed IP also in the range on 192.168.0.xx –  user37615 May 21 '10 at 0:30
    
Having researched the terms 'collision domain' and 'VLAN' I would confirm that YES all devices are on same CD and there is no VLAN configured.At any one time, the number of computers would not be more than 10. –  user37615 May 21 '10 at 0:47
    
Have you tried setting the lease time to some low value to test? –  dbasnett May 21 '10 at 13:52

I think the most likely cause of your problem has already been covered in the previous answers.

For some reason your DHCP thinks it has exhausted the pool of available IPs and thus is unable to provide one to a "guest". Then when the guest is unable to get an IP from DHCP its OS goes with a "link-local" IP.

The fact that a reboot of the router ... which also resets the DHCP IP pool ... seems to "fix" the problem is another reason why I suspect a problem with your router's DHCP IP pool management.

An easy way to explore this specualtion is to drastically increase the size of the IP pool available to your DHCP. If after doing this the problem either goes away or takes a much longer time to occur after rebooting the router, then I think this would imply a problem with freeing up the IPs after a DHCP lease expires.

If increasing the size of the DHCP pool results in no change, then it proves I'm an idiot. (Oh, well. I always suspected as much ...)

Have you looked at the log info for the router doing the DHCP? If there are filters for the log I would set them to whatever the highest level of verbosity is and after the problem occurs see if any of the log messages give you further insight. If your router allows emailing the log when it is full and "wraps", then I also suggest you enable that if you haven't already. Just to ensure you have a chance to see log messages which might be posted at the time the problem occurs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.