Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ubuntu 10.04 With Gnome

Every time Ubuntu goes to the screensaver and I unlock it, Firefox won't let me type anything. I can move the mouse and type in other programs... just not in Firefox. If I quit Firefox and reopen it again, I can type in it.

My keyboard connection is PS/2. Sounds buggish?


Update #1 - Hmm... this time around, I just waited for a minute and it appeared to return to normal. I still think it's a bug but at least it's not as bad as I originally thought.

share|improve this question
    
Coming from windows to ubuntu I have had so many problems with firefox and its addons. –  Zombies May 21 '10 at 19:36
add comment

2 Answers 2

I have experienced the same problem (Ubuntu 10.04 x64), and it does not go away; as soon as my machine resumes from monitor sleep, Firefox does not accept keyboard input.

My workaround is to bring up the System->Preferences->Keyboard dialog, which must toggle some widgets and reinitialize the keyboard. It works every time.

I've found that this behavior is accompanied by an error message that resembles this:

npviewer.bin[...]: segfault ... error X in libflashplayer.so[...]

I know that there are some problems with 64-bit browser/32-bit flash player (since the 64-bit flash player 10 has been pulled by Adobe), so I am not looking too far into the issue; we're lucky to have flash at all right now.

Edit: here is someone else complaining about the same issue: http://www.linux.com/learn/answers/4-distributions/425-losing-keyboard-input-on-firefox-on-wake-also-random-xserver-restarts

share|improve this answer
add comment

I confirm this strange behaviour. I use Minimize to tray extension, so I have to pkill firefox each time.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.