Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

apologies if this has already been asked - I couldn't spot anything exactly the same.

I'm looking for help on the fact that Windows XP has suddenly decided to stop assigning a drive letter to the second partition on my laptop's disk. I haven't added or changed hardware and I keep everything pretty clean in terms of software installed.

I've partitioned the disk into a system partition on C: and a user partition on d: but lately, when booting or coming out of hibernation or sometime from stand-by, Windows will lose it's d: mapping. If I notice and remap it from MMC, everything will be perfectly happy and will keep going.

Any help on this will be greatly appreciated.

Cheers, Kev

Quick update: its a bit sporadic - did some work this morning at home and drive was missing after wake up. Hibernated it, went to client site and everything OK. Beginning to wonder if the disk is giving up.

share|improve this question
Have you tried manually changing the drive letter to a different letter? Maybe it is something specific with that letter (D:) – admintech May 20 '10 at 8:43
No, haven't tried that, but like I said it's lived on D: quite happily (for 2 years) and only recently started playing up. – Kev May 20 '10 at 12:01

The following article, although USB-centered, might help:
Find Your Missing USB Drive on Windows XP

It explains how XP is capable of renaming a drive to a letter that is already in use, therefore it suddenly disappears. You might have made some hardware changes that have confused XP regarding the second partition.

As explained in the above article, you should from the Computer Management screen, select Disk Management, and then assign the partition a drive letter. Make absolutely sure that the drive letter is not already used (if it is, rename the other drive or use another letter).

But if the second partition is not visible in Disk Management, then you are in big trouble.

I wonder if the problem only occurs because some USB drive was previously assigned the letter D: before D existed. You might need to find that USB drive and rename it.

If the problem is only when coming out of sleep, make sure that the power-management options of the drive are set correctly.

You might also look in your BIOS for the suspend ACPI options and try to switch modes among "S1 and S3", "S3" etc until you find one that works for you. If none works, return it to its initial value.

share|improve this answer
Thanks, but it's nothing to do with a USB drive having been assigned that – Kev May 20 '10 at 12:05
@Kev: Even if USB is not the problem, read as well the later part of my answer. – harrymc May 20 '10 at 13:07
True, I'll check that out. Ta. – Kev May 20 '10 at 15:52

If the machine has a CD-ROM is this drive getting the D: assignment?

Quite apart from the actual issue and its causes please, please make sure you've got a backup of all your data. Issues like this can all too often prove to be terminal!

share|improve this answer
No, the CDROM is still keeping its e: drive - no change there. Backup happened pretty quickly I can tell you :-) – Kev May 20 '10 at 12:02

After a bit of research, the problem you describe is somewhat common, re: hard drive letter assignments disappearing after waking from sleep/hibernation. The common thread I've found is an update to the AHCI configuration.

The solution looks to be fairly long winded in that you'll need to check your bios settings, SATA connections, possible driver updates, etc...

If I had an exact solution for you, I'd post it :) Alas, you'll need to dig through the following links to find what works for you:

share|improve this answer
Thanks for this - I'll check them out. – Kev May 20 '10 at 15:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .