Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm a Linux newb so please try to keep the lingo low-key. I installed the latest nVidia drivers on my laptop using the 9800M card. The laptop is a Gateway P-7805u and I'm connected to the second monitor using VGA.

Also, before installing the nVidia drivers (and just using the basic drivers included with Kubuntu 10.04), basic dual monitor support worked, except I could not enable compositing features for some reason. So I thought the proprietary drivers would fix this.

Several issues have arisen since installation:
1) I've clicked through all of the display settings to activate the second screen with absolutely no change.
2) When I try to apply settings and Save Configuration as the nVidia help suggests, I am told that I cannot save to the X.conf file. I assume this is due to innate permissions on my user settings, which I have no idea how to properly configure.
3) I have no idea where to go from here, as most of the fixes I found online involve Linux syntax and verbiage, to which I'm totally clueless after spending over half my life with Windows.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

First, open a terminal and type:
sudo nvidia-xconfig

After that, do a reboot just to be sure. After the boot, open a terminal and:
sudo nvidia-settings

That's all I guess.

share|improve this answer
    
I believe this is exactly what I did, except through the GUI. At least, I had the nVidia icon added to the Settings menu and I could open that just fine. The problem was when I tried to change any settings within that and click Apply. The program would continuously tell me that it could not overwrite the X.conf file. –  NoCatharsis May 24 '10 at 17:47
    
Yeah because with sudo nvidia-settings you run the application as a super user. Means you can save into the Xorg file. Try it. :P –  Shiki May 24 '10 at 19:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.