Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

To put it bluntly, mplayer is unable to correctly play video DVDs. It seems to correctly find the title and everything, but the picture is broken or not displayed at all, with messages like:

a52: CRC check failed!
a52: error at resampling                                           
[mpeg1video @ 0xa8d840]sequence header damaged                     
[mpeg1video @ 0xa8d840]Missing picture start code

Now, this all is on amd64 Gentoo Linux system. I believe the problem is not in mplayer itself, since the playback also breaks in VLC or when i copy the VOBs via vobcopy and try to play them afterwards.

I use libdvdcss-1.2.10 and libdvdread-4.1.3_p1168 (current stable in Gentoo), and tried previous versions of both libs, but it didn't change a thing.

The DVDs I have tried play fine in regular DVD player or on a Windows laptop. I remember the playback used to work about a year ago and I don't know what to try next. Any hints would be welcome.

share|improve this question
1  
Imho the DVD is borked, you should just try to rip it on the Windows laptop. –  Shiki May 20 '10 at 20:53
add comment

1 Answer

up vote 0 down vote accepted

I've got it! It's caused by multithread decoding I have enabled. For some reason it b0rks MPEG-2 decoding. If I remove the setting (or use -lavdopts threads=1) everything is fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.