Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a PC and a laptop (Windows 7 - both) which should connect through router to Internet. The router is Linksys wrt120. My ISP is using PPPoE.

I have connected the Internet cable to the router, clone the MAC of my PC, writing the username and the password for my Internet connection. After seconds the router has acquired IP from my ISP. I have used the administration panel of Linksys and with the help of the ping and tracert commands which are built into it - I can connect to the world, outside the network.

The problem is when I try to connect the PC or the laptop to the network. There's no problem here. The DHCP server of the router gives them appropriate addresses. The problem is that they couldn't connect to either Internet addresses (google.com) or IP addresses. But they can connect to the router and its control panel.

I tried several times, reset the router..but there's no Internet..still.

One more thing: Windows 7 says after a diagnostic: "Your computer appear to be correctly configured, but the device or resource (DNS server) is not responding."

share|improve this question
    
Thank you to all but I find the solution (and the problem). My ISP has set the TTL to 1...so I have to change the router :) –  TheMouse May 21 '10 at 8:01
add comment

6 Answers

You might not have to clone your MAC at all if I remember correctly. But it has been a long time since I needed to use PPPoE.

Try to configure with out cloning the MAC and see what happens. Also verify that you are not using some sort of MAC filtering on your router. If you are be sure to add the needed MAC addresses of your local systems.

share|improve this answer
    
It is needed (the change of the MAC) because my ISP is filtering by it :) –  TheMouse May 20 '10 at 21:24
    
Sounds like a fun ISP to deal with. –  Tim Meers May 21 '10 at 12:34
    
MAC filtering, modified TTL...I'm wondering what will follow :D –  TheMouse May 21 '10 at 13:30
    
Most likely port "blocking" (stupid Charter and their port 80 shenanigans ......) it's my next most favorite thing. –  Tim Meers May 21 '10 at 14:02
add comment

If dns-troubleshooting wont solve it, try and reset your router to default(factory) settings and start over with a clean plate.

share|improve this answer
add comment
up vote 1 down vote accepted

Thank you to all but I find the solution (and the problem). My ISP has set the TTL to 1...so I have to change the router :)

share|improve this answer
add comment

If this is a DNS related problem, as the error message suggests, it's worth checking to see if you have any connectivity at all.

Open a command prompt and type:

ping www.google.com

See if you get any replies. if not try:

ping 74.125.232.20

Again, see if you get a reply.

If the former fails and the latter works, it means you're not correctly configured to resolve DNS addresses. This is probably a configuration in the router.

share|improve this answer
add comment

This happened to me last night. Turns out there was a problem with my ISP and the modem wasn't getting any connection to the internet (though I did have connection to the router).

It resolved itself after about half an hour. As Pulse stated, make sure you check if you can even connect to the internet at all. It may be an ISP problem, or it may be DNS issues.

share|improve this answer
add comment

Check If both the PC and laptop are set to automatically obtain the DNS server.

For more things to check, see 10 Ways to Troubleshoot DNS Resolution Issues.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.