Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

AMD PC Motherboard - Asus M3A78-EM (installed VGA drivers from Asus website - AMD_VGA_V863200_XPVistaWin7.zip)

It has VGA and HDMI inbuilt ports (ATI Radeon HD 3200 Graphics 256MB) VGA is connected to my ViewSonic Monitor. HDMI is connected to LG LCD TV

OS - Windows 7 x64 Ultimate

Sometimes, when I reboot/start my PC, my ViewSonic display resolution changes and does not show the recommended value(1440x900) in Resolution Settings. The HDMI display works well always.

But after multiple reboots/starts, the problem gets fixed automatically and I get back my recommended resolution on ViewSonic display.

I am not making any changes to the existing drivers. It sometimes work well, and sometimes doesn't work. Can someone assist me resolving this permanently.

share|improve this question
    
Once again my resolution is changed and I am not getting the recommended resolution of 1440x900. I have restarted my PC multiple times, but still the problem exists. –  kamleshrao Jul 27 '10 at 17:30

3 Answers 3

Every time you boot the machine, your video hardware drivers are loaded and caused to execute their initialization routine. Part of that task involves reading the EDID information from all connected monitors. If your video drivers fail at obtaining that information (which includes monitor preferred resolution) then monitor resolution is set to some value that somebody judged suitable for a "generic" monitor and you are given a limited set of other resolutions to choose from. The technology involved in this process seems to be rather delicate and failure-prone, in my experience. One of the things that can cause failure is a damaged or out-of-spec connecting cable or connector, and in your case using a new, high-quality VGA cable may solve the problem. Or maybe not. Some video driver software allows you to set up and choose a custom resolution for your monitor no matter what the EDID says.

share|improve this answer
    
Thanks for the insights on how it handles this internally. –  kamleshrao Dec 29 '11 at 5:39

This resolved the problem for me in Windows XP SP3:

  1. Uninstall the drivers.
  2. In setup adjust the UMA Frame Buffer Size for 256MB.
  3. Install the drivers.
share|improve this answer

As mentioned by kreemoweet, it is to do with the loading of the drivers, I sometimes get the same issue and rebooting my machine usually resolves the issue. However, if you don't want to reboot your machine everytime you can disable and then re-enable your graphics card: Device manager > display adapters > (mine is called: Intel HD Graphics) but yours maybe different. Right click and then click disable - and then right click and enable. This should resolve your issue without the need for a reboot :) www.apexsheep.co.uk

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.