Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought a new wireless setup, consisting of a Cisco E2000 router, Edimax 7718un USB adapter for my laptop and an Edimax 7728in PCI adapter for my HTPC (which isn't in a location I can run cat5 to).

I have to stay in the 2.4GHz band because I have an iPhone and a Wii that will need to connect. I'm aware that 11g devices will drop speeds for 11n devices, but they aren't connected yet.

The fastest connection I've been able to get, with the router within 5 feet of either the laptop or HTPC is 144Mbps. The router has settings for "20MHz" and "Auto (20 MHz or 40Mhz) channel width, which I've set to the "Auto" setting. I haven't been able to find anything similar for either of the Edimax adapters.

This is the first I've dealt with 11n, so I'm not even sure what else could be causing a problem. How do I get up to 300Mbps, or at least a fair bit closer?

share|improve this question
    
After just letting it sit for 30 mins or so, I noticed the connections on both my HTPC and laptop had improved to 270Mbps. Odd. –  Daniel Schaffer May 21 '10 at 3:03
add comment

2 Answers

up vote 24 down vote accepted

To get 802.11n's 300mbps signaling rate, you have to do two spacial streams (a.k.a. 2x2, or 2T2R), 40MHz channels, and a short (400ns) guard interval (short GI). The fact that you're seeing a 144mbps signaling rate indicates that you've got the 2x2 and short GI right, but you're only using 20MHz channels instead of 40MHz.

I know there are some products that refuse to do 40MHz channels in 2.4GHz because that takes up too much of the 2.4GHz ISM band's space, leaving no room for other uses of the band, such as Bluetooth (including your Wii Remotes). But reviewing the specs of your Cisco/Linksys E2000 and those Edimax products, it seems like they should all support 40MHz operation in 2.4GHz.

The IEEE 802.11n spec has a provision for 802.11n devices to signal that they are "40MHz intolerant", to try to get 40MHz-capable 802.11n gear in their area to limit themselves to 20MHz channels. For instance, a laptop with an 802.11n adaptor and a Bluetooth adaptor might signal this when it's using a 2.4GHz 802.11n AP that is 40MHz-capable. However, I'm not aware of any vendors that actually set or honor the 40MHz intolerant bit at this time.

My best guess is that you're hitting an interoperability bug. For some reason, your Edimax clients don't want to join your Cisco/Linksys E2000 using 40MHz channels even though your E2000 is configured for it.

802.11n talks of 40MHz operation in terms of two traditional 20MHz channels used together. The "control" channel is the main channel that both 20MHz and 40MHz-capable clients use, and the "extension" channel is the part that the 40MHz clients use. The extension channel can either be "above" or "below" the control channel, as long as it doesn't go outside the band. For example, if your control channel is 1, your extension channel has to "above", because anything below channel 1 would be below the lowest frequency allowed in the 2.4GHz ISM band. The extension channel has to be contiguous with the edge of the control channel, without overlapping. Because most of the 2.4GHz 802.11 channels overlap, channel 5 is the "above" channel for channel 1. There are varying notations for the control and extension channels. Often the control channel number is given, followed by a [+]1 or a -1 to show that the extension channel is above or below, respectively. So the situation I described as control channel on 1, extension channel on 5, might be shown as "1,1" or "1,+1" or even "1+".

In the US, Canada, and any other country that adopted US FCC-like regulations where we only have 11 2.4GHz channels, there are 14 valid control/extension channel layouts, but only 4 of them are commonly used, because it's a good idea to stick to the non-overlapping channels of 1, 6, and 11.

 1,+1 ( 1 &  5) common  
 2,+1 ( 2 &  6)  
 3,+1 ( 3 &  7)  
 4,+1 ( 4 &  8)  
 5,+1 ( 5 &  9)  
 5,-1 ( 5 &  1)  
 6,+1 ( 6 & 10) common  
 6,-1 ( 6 &  2) common  
 7,+1 ( 7 & 11)  
 7,-1 ( 7 &  3)  
 8,-1 ( 8 &  4)  
 9,-1 ( 9 &  5)  
10,-1 (10 &  6)  
11,-1 (11 &  7) common  

Europe, or any other region that follows the ETSI regulations, would add the following possibilities:

 8,+1 ( 8 & 12)  
 9,+1 ( 9 & 13)  
12,-1 (12 &  8)  
13,-1 (13 &  9)  

I suppose it's possible that your AP or your clients can't handle every possible valid combination of (control,extension). Or maybe you left your AP on channel auto-selection and it was accidentally auto-selecting an invalid combination like "11,+1". You might try manually setting your AP to "1,+1", as that's a pretty common arrangement, and see if your clients can handle that.

Another thing to check is your encryption type. Make sure you've got AES-CCMP (WPA2) enabled. The RC4 stream cipher engines included in early 802.11 chip hardware (used poorly by WEP, and less poorly by TKIP) generally can't keep up with 802.11n speeds. Because of this, the IEEE 802.11n spec requires that AES-CCMP be used for 802.11n connections. Unfortunately some vendors haven't done a good job of enforcing this in their setup UI, so they may have allowed you to choose 802.11n mode without requiring AES-CCMP to be enabled. It's unlikely, but within the realm of possibility, that your clients are seeing that the AP isn't set up for AES-CCMP, and so are limiting themselves to data rates they know their RC4 engines can handle.

"No security" is also valid, so if you're in a situation where you don't need your data-link layer to provide confidentiality, you can always go that way.

Overall, if it's not too late to return your new wireless gear for a full refund, I'd recommend you return it all and pick up a simultaneous dual-band AP (your Cisco/Linksys E2000 is only one band at a time), and dual-band wireless client cards (your Edimax cards are 2.4GHz-only). That way you can use fast 40MHz channels in the less-crowded 5GHz for your PCs, and leave your legacy devices to use a 20MHz channel in 2.4GHz, leaving enough free space in the 2.4GHz band that it doesn't screw up your Wii Remotes, other Bluetooth devices, and other devices using the 2.4GHz band. Some of the latest gear that has come out in the last few months supports 3 spacial streams (3x3), allowing for signaling rates up to 450mbps. Look up the Wi-Fi certificate for the devices you're thinking about purchasing, and make sure they're certified for "final" (not "draft") 802.11n, 2 or 3 spacial streams, 40MHz operation in 5 GHz, WMM, and all the rest. Here's a good example.

share|improve this answer
2  
+1 for another crazy-good Wifi answer. :) –  techie007 Dec 2 '11 at 0:57
add comment

As has already been mentioned, 300Mbps is an essentially fictional marketing term. This is actually the first point discussed in the article over at smallnetbuilder.com I'm recommending.
Here's a link to it: 5 Ways To Fix Slow 802.11n Speed

I think you may already be familiar with most of what it covers. But the last point about the pitfalls of using "channel bonding" (aka 40 MHz bandwidth) might possibly be of interest.

What tools are you using to measure you "actual" throughput? With my 802.11n I never seem to get much above, say, 10 MiB/sec (more typically it's 6-8).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.