Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just upgraded to Ubuntu 10.4 from 9.10, and it's now hiding the hibernate and suspend options. How do I get them back?

So the way you do this is make sure that your swap partition is in /etc/fstab and swap is enabled, and big enough. Look at /proc/swaps to see if anything is listed.

Now I'm getting this error when I boot after suspending:

init: ureadahead-other main process (705) terminated with status 4

Does anyone know how to fix this?

I'm using Ubuntu with kernel 2.6.32-22-generic.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Make sure you have a resume= line in your /boot/grub/grub.cfg for grub2, or /boot/grub/menu.lst for grub.

You should have lines that say:

linux (blah blah blah) root/dev/$ROOT_PARTITION resume=/dev/$SWAP_PARTITION

Or if you're using UUIDs, obtained from running sudo blkid:

linux (blah blah blah) root=UUID=$UUID_ROOT_PARTITION resume=UUID=$UUID_SWAP_PARTITION

Where all words like $WHATEVER are either device nodes or partition UUIDs.

share|improve this answer
    
thanks much. I'd only been searching for that bit of magic for a month ;) –  msw Jun 18 '10 at 7:40
    
I asked the grub developers and they said it has nothing to do with the bootloader. Go figure. –  Neil Jun 19 '10 at 2:19

Can you see a battery / plug icon in the tray? If no, GNOME power manager is probably not running, so you need to start it / add it to the tray. If yes, does it show the hibernate option?

As a workaround, you can also suspend/hibernate from the CLI:

acpitool -s #suspend
acpitool -S #hibernate
share|improve this answer
    
pm-hibernate #--help for options ||| pm-suspend #--help for options –  Shiki May 21 '10 at 8:32
    
does acpitool work for shutdown as well? –  Dom May 21 '10 at 10:03
    
@Dom: No. That's what shutdown is for :-) (most modern Linux distros also have poweroff). –  sleske May 21 '10 at 12:02
    
Oops! Thanks, didn't know those. –  Dom May 24 '10 at 7:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.