Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My ISP has set up the TTL to 1. My current router Linksys WRT120N can't change this and my computers don't have connection to Internet.

I will return my current router and take another. I have some options:

  • D-Link DIR-615
  • D-Link DIR-320
  • Linksys WRT54G2
  • Linksys WRT54GL

Is the last router the only fix (among these routers) to my problem?

( I have to buy the router from this shop: .. the site is in Bulgarian but at least the models which I can choose from are there in English.)

share|improve this question
up vote 5 down vote accepted

I assume that your problem is, that all incoming packets have a TTL of 1 which results in their deletion by the router. Clever idea of your ISP :)

Anyway if you use alternative router firmware like DD-WRT, OpenWrt, etc., you should be able to modify the firewall (iptables) rules to set the TTL to a different value (iptables has a --ttl-set option). The DD-WRT wiki has some information about that:

share|improve this answer
I think this means, you should purchase the Linksys WRT54GL in order to run DD-WRT or OpenWrt on it. – kmarsh May 21 '10 at 13:16
I have decided to try DIR-615 with DD-WRT...I hope it will work. – TheMouse May 21 '10 at 18:55
Very nice answer, +1. – Josh K May 26 '10 at 14:22

Indeed there are some small ISPs (neighborhood size) which link you directly to their equipments over Ethernet cable and they set TTL=1 in the DHCP packets.

Authorization in their network is based on MAC address of your network card.

They also state that you are not allowed to use a home router unless you buy a higher subscription (lame).

As a possible solution:

  • I have an Asus WL 500gp V2 wireless router for which I am planning to install OpenWRT so can I have a small linux box I can connect to using ssh where I can change TTL settings of my outgoing packets.
share|improve this answer

Excuse me, but I'm not sure exactly why you have to change your router (I saw your earlier post) TTL (Time To Live) is a process that's applied to an IP packet as it passes through a router. Invariably, as a packet transits a router, the TTL is decremented by 1. Basically, every packet has a finite time to live and the TTL ensures that if a packet is not delivered, it dies.

Essentially, I'm not sure that changing your router is the solution.

share|improve this answer
Pinging [] with 32 bytes of data: Reply from bytes=32 time=223ms TTL=1 ... ""TTL ensures that if a packet is not delivered, it dies"" - yes, exactly..but what happend if TTL=1 - the packet can make only one hop. – TheMouse May 21 '10 at 9:22
Thank you for the answers to my posts :) – TheMouse May 21 '10 at 9:24

Ignoring the TTL question, have you called your ISP and told them that you can't get to the internet? I have made the assumption that you are doing other things besides pinging, and they do not work either.

Also, regardless of what you set your TTL to, you will not be able to control the first ISP router and what it does. Here I have set the ttl of the ping to 64.

C:\Documents and Settings\myPC>ping -i 64

Pinging [] with 32 bytes of data:

Reply from bytes=32 time=66ms TTL=112
Reply from bytes=32 time=67ms TTL=112
Reply from bytes=32 time=66ms TTL=112
Reply from bytes=32 time=66ms TTL=112

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 66ms, Maximum = 67ms, Average = 66ms
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .