Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can phpMyAdmin (running on Ubuntu 10.04) be restarted after the /etc/phpmyadmin/config.inc.php file was changed?

share|improve this question
    
I've never liked using a package manager for phpMyAdmin. I've always found it easier and faster to download directly form phpmyadmin.net, copy the sample config file to config.inc.php, and edit that –  wag2639 May 23 '10 at 14:51
1  
What does this have to do with the question anyway? It's about how a change in the config file gets applied. –  BloodPhilia May 23 '10 at 15:43
add comment

3 Answers

up vote 7 down vote accepted

No need to restart phpMyAdmin, changes in /etc/phpmyadmin/config.inc.php are automatically applied.

share|improve this answer
    
so why when uncomment :$cfg['Servers'][$i]['AllowNoPassword'] = TRUE; I get still message: Login without a password is forbidden by configuration (see AllowNoPassword) –  Yosef May 21 '10 at 14:43
    
Are you using root account without password? And which version of PMA are you using? –  BloodPhilia May 21 '10 at 14:50
    
i am using as root and 4.3.3 –  Web Developer Dec 15 '10 at 5:39
    
@Yosef: been there too. There are 2 lines in config file with this setting. I'm not sure which one needs to be uncommented, but if you do just one - 50% chance is that's the wrong one unless you know exactly what you are doing. –  tishma Sep 29 '12 at 11:20
add comment

I was in a similar situation on Ubuntu 10.10 (phpmyadmin 3.3.7deb3build0.10.10.1) and even after editing /etc/phpmyadmin/config.inc.php I couldn't login (because of AllowNoPassword).

I had to cp /usr/share/phpmyadmin/config.sample.inc.php /usr/share/phpmyadmin/config.inc.php and then add the $cfg['Servers'][$i]['AllowNoPassword'] = TRUE; line to it.

It is strange, but it worked.

share|improve this answer
    
The same issue with me. It seems that Ubuntu ignores /etc/phpmyadmin/config.inc.php but loads /usr/share/phpmyadmin/config.inc.php. Uncomment "Storage database and tables" section and "Designer" mode will be enabled. –  bancer Oct 14 '12 at 19:02
add comment

Try and open it using:

sudo gedit /etc/phpmyadmin/config.inc.php

Uncomment it and save, but keep it open - then try opening phpMyAdmin. It should work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.