Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Platform: Windows XP SP2, Excel 2007

Problem description: Upon clicking on a file in Windows Explorer (file is either .xls or .xlsx) Excel 2007 opens, but does not open the file itself. I need either to click on a file again in Windows Explorer or open it manually with File/Open ... from Excel.

Does anyone know what could cause this rather strange behaviour ?

The old versions of Excel worked "normally" ... i.e. upon clicking on a file, an Excel would open along with the file.

Please, help !

share|improve this question
add comment

3 Answers

Right click & open with Internet Explorer. It will be redirected to the Excel program and the file should open.

share|improve this answer
add comment

It sounds like the file association is broken. Normally a file association string would pass in the value for the current file as a parameter, effectively saying "start application X and open file foo.bar"

A repair of the Office install should fix this, or you could try right click > open with > browse to Excel.exe and tick the box for "always open with this program". If you edit your tags or question to tell us what operating system you are using, we can give you more specific step-by-step instructions on these options.

share|improve this answer
    
No, the association is there or Excel wouldn't open! Also, it works if william double-clicks a spreadsheet file while Excel is already open. It's pretty clearly an Excel bug, IMO. –  CarlF Sep 30 '11 at 18:31
    
The association could be broken, for example to tell Excel to open but not pass in the filename parameter properly, but I accept this is less likely. I was hoping to be able to help with something which had been unanswered for over a month, but it looks like it did not fix it or the OP has not been back. –  AdamV Oct 17 '11 at 15:52
add comment

Click the big round button at the top left, click Excel Options at the bottom of the dialog that appears. Then go to Advanced -> scroll down to General and uncheck Ignore other applications that us Dynamic Data Exchange (DDE)

share|improve this answer
    
It is already unchecked (afaik, it's like that by default; I haven't changed anything since the install). –  user37902 May 21 '10 at 15:16
    
Check it then, close Excel, re-open Excel, uncheck it, and see if that helps. –  user3463 May 21 '10 at 21:16
    
@Randolph Potter - No. No combination works. Oh well, maybe it's even better this way - I'll have an extra argument to give to IT guys when explaining why I want them to put me back on version 2003. –  user37902 May 21 '10 at 21:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.