Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I run 64-bit Windows 7 Ultimate off a Corsair 128GB SSD (cmfssd-128gbg2d) and I've got two older HDDs I use for storing media. However even though the operating system and all the programs are installed on the SSD, frequently when I'm starting programs, I can hear the computer spin up one of the HDDs before the app starts and I'm not sure why (and I don't know which drive it is).

For programs that should open very quickly - Programmer's Notepad, Calculator (the basic one that comes with Windows), etc. - having to wait several seconds sometimes can be pretty obnoxious. Avoiding wait times like that are why I got the SSD in the first place.

Is there any way to tell why that's happening? I'm happy to provide more information but I'm not sure what's important. Any help would be really appreciated!

Edit: I'm not sure it's a memory related issue. I have 6GB of RAM and I hardly ever use more than 2 or 3 so I'd be shocked if there's lots of paging or running out of memory going on.

share|improve this question
    
I have noticed exactly the same problem with my Intel X25-M SSD. A brute force solution would be to never allow the hard-drives to turn off; hardly satisfactory though. –  sblair May 30 '10 at 13:11
add comment

3 Answers

Make sure your pagefile isn't configured to use the other hard drives.

  1. Right-click on My Computer and click Properties, then click the Advanced tab
  2. Under the Performance section, click Settings, then click the Advanced Tab
  3. Under the Virtual memory section, click Change
  4. Click on each hard drive in the list. If you don't want the drive to spin up, click the
  5. No Paging file radio button and click Set.
  6. When you're done, click OK and reboot the computer.

Note that you should leave the pagefile configured on at least one drive. If you have a large amount of free space on the SSD, you'll get the best performance out of that. However, if the SSD is almost full, you might want to put the pagefile on a different drive since the write leveling algorithms won't have enough space to effectively distribute the writes.

Update: another possibility might be Windows Desktop Search, or any other desktop search tool you have enabled. If you don't need the search capability on those drives, you could disable indexing on those drives.

share|improve this answer
    
It was actually already set up that way but thanks for the suggestion! –  ZorroDeLaArena May 21 '10 at 19:57
    
Another possibility might be Windows Desktop Search; I've updated my answer. –  rob May 21 '10 at 20:06
    
I am using Google Desktop but I'm not sure why starting Calculator would trigger it to suddenly start indexing one my HDDs. I'm turning off the indexing though. I'll post if that helps. –  ZorroDeLaArena May 21 '10 at 23:06
add comment

The culprit could also be Superfetch, which may be caching images of the app's memory usage on your HDDs in a silly attempt to speed up boot time. Try disabling it.

share|improve this answer
    
Tried this. Didn't fix it. Thanks though! –  ZorroDeLaArena May 21 '10 at 23:03
add comment

It should be possible to run Process Monitor from Sysinternals and configure it to monitor file activity but your system drive.

You should then be able to tell which process is triggering the disk access and what file it is looking for, which might help stop it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.