Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've tried tightvncserver and vnc4server on Ubuntu. I've tried tightvnc viewer and ultravnc viewer on Windows XP. I can connect from Windows to Ubuntu with any combination, but there is no screen refresh: I can drag a window on Ubuntu using my mouse in Windows or type into a terminal in Ubuntu from my keyboard in Windows, but the image does not change on Windows. I can request a screen refresh from Windows but the screen does not update.

I am running the ATI driver on Ubuntu. I've tried stepping the System|Preferences|Appearance|Visual Effects down from Extra to Normal with no effect.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Moved System|Preferences|Appearance|Visual Effects from Normal all the way down to None. VNC works.

share|improve this answer

As an alternative to completely disabling desktop effects, you may also try (on the remote host you are attempting to view via vnc) running "gconf-editor", and go to /desktop/gnome/remote_access and enable "disable_xdamage"

share|improve this answer

I've tried different ways without success, but I found the solution while I was fixing another issue:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.bak

If file doesn't exist:

sudo nano /etc/X11/xorg.conf

Add the following content:

Section "Device"
Identifier "ATI Radeon"
Driver "ati"   
Option "AccelMethod" "EXA"
Option "MigrationHeuristic" "greedy"
Option "AccelDFS" "true"
Option "EnablePageFlip" "true"
   Option "EnableDepthMoves" "true"
EndSection
Section "Monitor"
Identifier  "Configured Monitor"
Vendorname  "Samsung"
Modelname   "Samsung SyncMaster 793S/793V/CM173G"
Horizsync   30-71
Vertrefresh 50-160
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
modeline "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
modeline "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
Gamma   1.0
EndSection
Section "Screen"
Identifier  "Default Screen"
Monitor  "Configured Monitor"
Device   "ATI Radeon"
Defaultdepth    24
SubSection "Display"
Depth   24
Modes    "1024x768@70"  "1024x768@60"   "1024x768@75"   "1024x768@43"   "1024x768@85"   
"1152x864@75"   "832x624@75"    "1280x960@60"   "800x600@60" "1280x1024@60" 
"800x600@85"    "1400x1050@60"  "800x600@75"    "800x600@72"    "800x600@56"    
"640x480@85"    "640x480@75"    "640x480@72" "640x480@60"
EndSubSection
EndSection

Now startx and it should work...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.