Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Operating System: Windows 7 (x64)

Problem: Certain Programs are unable to access the internet. They claim that there is no connection when you already are connected.

I just installed Windows 7 on my laptop and I have a few problems.

I play World of Warcraft, as well as a variety of games. And when I first attempt to log into the game, I get a Windows error message, but it doesn't stop there. I thought World of Warcraft got corrupted during the upgrade. It seems that I am unable to access the internet from other online games as well. Most say in along the lines of

"Cannot connect to patch server, try again later. "

I cannot use a downloader

Also, I have Internet Explorer. The x32 version of the browser cannot connect to the internet, and when I try to enter "", it says the same thing. I'm only accessing this site through Internet Explorer x64, which I would have been fine with is it's compatible with Adobe Flash.

The only thing that seems to connect to the internet are Internet Explorer x64 and Windows Live Messenger.

Here are the steps I have taken, but none worked.

1.) Disable Windows Firewall

2.) Have Windows Firewall Enabled, but allow the specific programs to access internet. And allowed all incoming access.

3.) Disabled UAC, Ran the programs as an admin, and set compatibility to Vista.

4.) Uninstalled an anti-virus program. (McAffee Security Suite 2010)

5.) Reinstalled the programs

6.) Reinstalled Windows 7

7.) Retaken the steps on the Administrator account.

share|improve this question

It sounds like 64 bit applications can access the internet but not 32 bit ones. I would think that the WoW (that's Windows-on-Windows, not World of Warcraft) layer is loading a different Winsock stack to the native one.

You can try resetting Winsock and the TCP/IP settings on the interface.

Try and

Bear in mind that resetting the Winsock catalog will require you to reinstall any third party software that depends on LSPs (like antivirus).

Also check that you don't need a proxy to access the internet and the proxy is set in IE8 x64 but not IE8 x86?

And allowed all incoming access.

If you are behind a NAT this is not so bad, but on a direct connection to the internet this is not very safe.

share|improve this answer
+1. I had a similar problem the other day where resetting Winsock fixed it. – user3463 May 22 '10 at 3:28

You must log in to answer this question.