Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm new to networking. I'm trying to share a folder between to computers (both have kubuntu 10.04 installed). I'm able to share a folder with samba and can see that folder through samba on the same computer. But if I try to go on the other PC I can't see the first one. Both PCs are on the "workgroup" workgroup. I've tried disabling the firewall with firestarter

can somebody help me?

thanks

update: here's my samba.conf http://pastebin.com/SpuES468

share|improve this question
    
First things first. Can you ping each computer from the other? –  I-Ii May 19 '13 at 1:30

3 Answers 3

Check your samba config in /etc/.

Samba often works only if you set it up by hand. It is most likely located here:
/etc/samba/smb.conf

You can edit it by opening a terminal and typing: sudo kate /etc/samba/smb.conf . (It'll ask for a password and open the file.)

However, make a backup of the file. And if you feel like you can't fix it, just paste your config to http://pastebin.com , give me the link and I'll have a look.

share|improve this answer
1  
I'd say if one is not sure what they are doing it is better to edit smb.conf via swat. Swat will make sure the configuration file is syntactically correct and minimizes misconfiguration. –  I-Ii May 19 '13 at 2:28

You need to put samba on both the machines. Need to make sure both are a part of same workgroup/domian. Also you need to make sure you have defined the folder in smb.conf

after that open Dolphin -> Samba Shares -> Workgroup -> (Your Machine)

or from command (CLI): smbclient //yourpc/urshare -L

share|improve this answer
    
You don't need samba on both machines unless you want to share files from both machines. Usually one machines becomes the samba server and the other(s) just use Nautilus (or similar) to get to the server. –  hotei Aug 15 '10 at 19:31

Try this; this will enable the drive to be seen (advertised) on the network.

append to /etc/samba/smb.conf

[INCOM]
path = /Data/Incoming/
guest ok = yes
read only = no
browseable = yes
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.