Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My system hard drive on an XP computer kind of failed (random corrupt sectors). So i got a new harddrive and am trying to recover the files. The filesystem is NTFS.

The system i'm trying to use when recovering the files is Windows 7. I'm obviously an admin on this box. The last data i'm trying to recover is stuff in the Documents and Settings folder.
I'm using a SATA to a USB cable thingy so that I just plug it in as an External Hard Drive.

The problem:
In Windows Explorer when i try to copy the data, I keep getting prompted with Security warnings and error messages. It keeps telling me i have to change the owner permissions of the folder and all it's contents. If i tell it to change all the files and folder permissions it takes a really long time because it has to recurse through all the folder contents to change the permissions.

Is there a way for me to ignore the file permissions when doing this?


share|improve this question
up vote 2 down vote accepted

No, there is no way to ignore NTFS permissions.

The best you can get is to change all permissions for the drive and all its contents. At least in XP there are two options:

  • Inherit from parent the permission entries that apply to child objects
  • Replace permissions on child objects

If you enable both once, then the permissions of every "child object" (file or folder) will be replaced with "Inherit from parent".

The first change may take a long time, but further ones should be really fast because only one object's (drive root) permissions will need to be changed - files inside will have "inherit" set and need no change.

share|improve this answer
Thanks. the first sentence pretty much answers my question. I tried using my macbook pro to read it but even it complained about not having permission to the files. I did end up biting the bullet and changing the permissions for everything. – w-- May 24 '10 at 18:30

You can use Robocopy in backup mode to copy files that you do not have permission for, but I suspect you will still have to take ownership of the new files.

However, since they will now be on the Sata drive it will not take as long than it would to do it via USB.

share|improve this answer
thats a great tip about robocopy in backup mode. As i've never had any problems with Windows file security and permissions in the past, I've never understood what "backup mode" might be for. – w-- May 24 '10 at 18:31

OS X has an option to ignore File Permissions on external drives, but Windows is too retarded for such Usability. I hope Windows will prove me wrong in future, because this UAC fuckery annoys me every time, which escalates in takeown rapes for hundred thousands of files, which damanges the disc in the long run.

To prevent such errors from happening, OS X includes a setting to ignore permissions on external drives, so all files on the drive should be fully accessible regardless of their permissions settings.

To set this option for external drives, select the drive on your desktop or in the Finder sidebar, and then press Command-I to get information on the drive. In the information window that pops up, go to the Sharing section and click the lock to authenticate. Then check the box to "ignore ownership on this volume," or toggle it off and then on if it's already enabled.

For Windows, there is AccessGain:

It's basically a driver, which just ignores the NTFS file permissions.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .