Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a wireless router at home and my MacBook Pro is connected to said wifi. My desktop doesn't have a wifi connection, but I've connected my MacBook with my desktop via crossover cable. I enabled internet sharing on my MacBook, but my Windows 7 desktop can't get a connection. I tried just regular file sharing and that works fine, but the internet sharing doesn't.

I assume the goal is to get my PC to see my Mac as the default gateway, but I've had no luck manually setting it. Here's the ifconfig output on my Mac and my attempt at settings on Windows:

enter image description here

I'll probably be buying a USB wifi adapter if I can't get this to work, but I'm trying.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Those screenshots were very helpful. You were on the right track when you enabled Internet Sharing on your Mac, but there were two main problems:

  1. You were accidentally using the same subnet for two separate networks (the ones on each side of the Mac). Using the same subnet for two separate networks is almost always a bad idea.

    A Mac running Internet Sharing acts as a NAT gateway and a DHCP server for the machines it's providing Internet service to. Mac OS X's Internet Sharing feature always uses the 192.168.2/24 subnet for this. So you'll need to change the configuration of your upstream home wireless router to use a different subnet, perhaps 192.168.1/24.

  2. Your Windows machine wasn't set to use the Mac as its router.

    When a machine is directly behind a NAT gateway, it must use the NAT gateway as its router. In this case, that would be the Mac's IP address on its NAT-private interface, which is 192.168.2.1.

    I'd recommend you set the Windows box to get its IP address automatically (via DHCP). The Mac's Internet Sharing feature's built-in DHCP server should configure the Windows machine correctly.

share|improve this answer
    
Thanks. This did the trick. I didn't realize the Mac was setting that by default. The reason the router was on 192.168.2/24 was because I have a wonky modem. Setting my router to 192.168.3/24 worked fine though. –  David Weitz May 24 '10 at 23:01

Your router must have at least one ethernet port, otherwise you wouldn't be able to connect to it to configure its password etc.

Just plug your PCs ethernet cable into that. You then don't have to do any configuration on the Mac, and the PC can connect "direct" to the internet.

share|improve this answer
    
I'm aware of that. It's just that the router is in my basement, and I want my desktop to be up in my bedroom. There's already a desktop hooked up to it and the router has been configured for a while now. I know there's extra spaces, but I don't want to run ethernet up through the walls. –  David Weitz May 22 '10 at 22:18
    
@David - fair enough, you should have included that in your question as it does have a bearing on the answers you'll get. –  ChrisF May 23 '10 at 10:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.