Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've had a Dell Latitude laptop since about 2000 without managing to destroy it. A month ago the Windows 2000 system on it did something stupid to its file system and Windows was completely lost.

No point in reinstalling Windows 2000, so I installed an Ubuntu 9.0 Linux on the laptop. Everything seems normal (installed, rebooted, I can log in, run GnuChess, poke about).

... but ... when I attempt to launch Firefox from the top bar menu icon, I get a bunch of disk activity, the whirling cursor icon goes round a bit and then

(WAS: everything stops: icon, mouse. Literally nothing happens for 5 minutes. Ubuntu is dead, as far as I can tell.

EDIT : on further investigation, spinning icon, mouse operated by touchpad freeze. [I don't know if external mouse has a problem] There's apparantly a little disk activity occuring about every 5 seconds, and the processor must be chewing up cycles, as the CPU fan comes on an stays on. I wait 5-10 minutes, behavior doesn't change)

A reboot, and I can repeat this reliably. So on the face of it, everything works but Firefox/other application. That seems really strange.

The only odd thing about this system when Firefox is booting is that while it has an Ethernet port (that worked fine under Windows), it isn't actually plugged into an Ethernet. As this is the first Firefox boot since the Ubuntu install, maybe Firefox mishandles Internet access? Why would that crash Ubuntu?

(I need to go try the obvious experiment of plugging it in).

EDIT: I tried to run the Disk manager tool, not that I cared what it was, just a menu-available application. It started up like Firefox, I get a little tag in the lower left saying Disk P*** something had started, and then the same behavior as Firefox. At this point, I don't think its the Ethernet. Is it possible that the Ubuntu disk driver can't handle the disk controller in this older laptop? The install seemed to go fine.

EDIT#2: More experimenation. It appears to be the screen drivers. If I switch Display Preferences to 640x480 using the GUI, everything seems fine (including Firefox startup) if you don't mind boulder-sized pixels. Alas, trying to switch away from that size using the to any other size seems to hang the machine hard (no disk I/O). Does UBUNTU have a display device selection control that I need to configure somehow?

EDIT#3: 6/10/2010: Installed UBuntu 10.x. Now seems to manage the screen OK. Guess just bad drivers for older Dell laptops in Ubuntu 9.x.

share|improve this question
add comment

2 Answers

It's not the disk controller I guess. It's something else. Install/launch opensshd on the notebook. After that, ssh your notebook through lan. I guess it'll be SSHable after the crash and you can check dmesg and /var/log/ folder for log files. How much ram you have? Maybe it starts to swap but it goes crazy after a time?

Let me warn you, Ubuntu is NOT for slower machines. If you want lightweight, you can try Crunchbang Linux for example. Or Zenwalk, Absolute, Puppy, there are so many choices if you are interested.


Here is the link for Launchpad bugs. Anyway, I found some strange hit on "Ubuntu"+"10.04"+"Firefox" through Google. (Not happened to me and never saw it on my fav portal, but it may worth a check). Also as I said, you could try out Fedora (or openSUSE 11.2?) (They are NOT lightweight basically. You'd have to use crunchbang for that if your pc's slowness is the problem.)


EDIT: You could try disabling compiz. Right click on desktop, background, and on the far right tab, you can select NONE. Try that. (or you have to disable kms).

Here it is. Read it, try the workarounds. At least one should work.

share|improve this answer
    
Thanks for responding. ... seems a screen driver problem, any thoughts? ... The laptop was high end when I got it. These days its probably just mediocre; I don't expect to crunch with it. Firefox and email will be enough. –  Ira Baxter May 23 '10 at 6:28
    
Yeah but Gnome is already a hog, and count firefox on the top of it. Its not for slow machines. Maybe it can be your video card. Intel driver is buggy on some Ubuntu release. Two basic options. Try it with Fedora (will be here in 3 days) or wait for a fix. ... posting link to EDIT. –  Shiki May 23 '10 at 6:36
    
Where did you get the fact "Intel driver is buggy on some Ubuntu release"? It sounds like my problem. –  Ira Baxter May 23 '10 at 7:29
    
Check the latest edit. Intel driver is always buggy on Ubuntu releases. (No not blaming Ubuntu, its Intel's fault). You can go with Fedora which ships more fresh drivers, or simply use those workarounds on the second link. –  Shiki May 23 '10 at 7:36
    
Uh, where do I figure out what "compiz" is, so I'm not afraid to turn it off? I see a bunch of references to in the Launchpad bug list, and it seems to have something to do with "xorg" (xwindows?). –  Ira Baxter May 23 '10 at 7:37
show 3 more comments
up vote 0 down vote accepted

Problem Resolution: I installed UBuntu 10.x. Now seems to manage the screen OK. Guess just bad drivers for older Dell laptops in Ubuntu 9.x.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.