Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm seemingly unable to configure my Flash Player settings in Mac OS X under random circumstances. I right click and select settings from the context menu, the dialogue comes up and it's not clickable.

Does anyone have a solution to this? Might it be the way I'm embedding my flash movie?

share|improve this question
    
Similar thread here: forums.adobe.com/message/2380605 Going to try reinstalling. –  Koobz May 23 '10 at 1:48
    
Any news on this? How did you solve it? Topic was just bumped to the front page. –  Daniel Beck Mar 30 '11 at 19:38

4 Answers 4

The solution to this rampant Adobe Flash bug introduced in Flash Player 10.1...or workaround more like... is to go to MegaVideo.com, play any video, choose Full Screen button, then right click and choose Settings. This will enable you to access the Flash Control Panel settings to make any changes. You'll still be bugged with no-click-ability when you return to the window view, but at least you were able to change your settings.

share|improve this answer

Check the Adobe Flash Player site, there are suggested workarounds in this bug report: https://bugs.adobe.com/jira/browse/FP-4656

Apparently the issue happens when the Flash movie is embedded at a position which is not on an integer pixel boundary, which can easily happen if you zoom the page in or out or center your Flash movie (or something the movie is in).

share|improve this answer

Off the top of my head, I would suggest you reset your flash settings. This is a cold-boot-like way to do that:

#! /bin/bash
rm -r /Users/[...]/Library/Preferences/Macromedia/Flash\ Player/macromedia.com/support/flashplayer/sys
mkdir /Users/[...]/Library/Preferences/Macromedia/Flash\ Player/macromedia.com/support/flashplayer/sys
rm -r /Users/[...]/Library/Preferences/Macromedia/Flash\ Player/#SharedObjects
mkdir /Users/[...]/Library/Preferences/Macromedia/Flash\ Player/#SharedObjects
exit;
share|improve this answer

In Koobz’s link, Thou Art Jay points out that it seems to be related to the CSS on the page. I’ve been able to get around the problem by loading just the Flash file directly in my browser. That is, if you look at the HTML for the page, there will be a link to a .swf file that corresponds to the Flash file. Copy that to your location bar and load it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.