Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I setup my router to forward port 80 to the PC hosting my web site. As a result, I am able to access this url (Don't bother clicking on it, it's just an example): http://my.url.com/

When i click on this link while running on the web sever, it works: http://localhost:8080/tfs/web/

I also forward port 8080 to the same web server box

But when I try to access this url I get the eror "Page Cannot be displayed:"

http://my.url.com:8080/tfs/web/

I fwded port 8080 the same way I fwded port 80. I also turned off Windows Firewall, in case it was blocking port 8080.

Any theories why port 80 works but 8080 does not?

The following shows my router config on that I am fwding traffic on both port 80 and 8080.

alt text

And I think my fiewall is completely disabled: alt text

share|improve this question
    
How are you accessing those -- from an outside computer, or from some computer on your own LAN? If the latter, then for the working port 80 you might have set up some proxy server to route the request though some outside machine? Maybe those settings only apply to 80, not 8080. And any differences when using your public IP address rather than the domain name? Any differences when using web-sniffer.net ? –  Arjan May 23 '10 at 19:58
    
To clarify on your edit. So you can access the webserver on port 81 but not 8080? –  Earlz May 24 '10 at 7:14

4 Answers 4

Have you tried accessing http://my.url.com:8080/tfs/web/ from a different physical computer outside of your network?

If you try to access a public IP address(as a public loopback of sorts) from inside a NATed network under the same public IP address then it will not work. Try typing http://my.url.com:8080/tfs/web/ into this website: http://downforeveryoneorjustme.com/ if it works, then the local-public NAT thing is the issue. If not then it's something else with your firewall/router/server..

share|improve this answer
    
I have, and it is down for everyone. I don't know what it could be. Check out my edited post. It shows my router configuration fwding both 80 and 8080. Also, the firewall is turned off on the web server. I'm, at a loss. –  Chad May 24 '10 at 0:27

Did you set up IIS to respond to port 8080 or are you using your router to map port 8080 to port 80?

Also, did you try using another computer on the network to test if port 80 actually works and then try port 8080 using IIS server's ip address.

For firewall issues, you can manually add ports to exclude. With Windows 7, theres an action to add "New Rules" (on the right) when you click on the "Inbound Rules" on the left.

share|improve this answer
    
Answers to your questions: (1) I did not set up the router to map port 8080 to 80. The web site is configured in IIS to use port 8080. (This is a TFS site, the setup program configured it this way.) (2) From another computer in my home using the local network IP address that starts with 192h, I can successfully access web site on the web server that are running on port 80. I can also access the TFS web site running on port 8080. Using an external IP address of my router, I can only access the web site on port 80. –  Chad May 24 '10 at 1:15
    
Since you can access both websites (ports) from another computer on the network, I suspect its your router and not your server. Try restarting it and redoing the configuration for the port (i know you already have it setup but computers are dumb and things that don't make sense often works) –  wag2639 May 24 '10 at 20:21
    
Very good point. Originally My PC was not fwding on any port. Then I reset my router to factory settings and, I believe) fwded port 80 exactly the same as I did when it wasnt working, and then it worked. Maybe I will try that again. Now, I am just considering switching my TFS web site from port 8080 to 80. Who knows what else I have to chg when I mess with the default... –  Chad May 24 '10 at 22:34

If you're on Windows using WAMP (or, more specifically, Apache; I don't know your exact setup), you need to go into Apache's httpd.conf file and replace "Listen 80" with "Listen 8080".

share|improve this answer
1  
...but http://localhost:8080/tfs/web/ works. –  Arjan May 23 '10 at 19:16

can you connect to port 8080 in the same network segment ? I.E. If you have a switch, can you reach the remote computer on that port ?

share|improve this answer
    
Woah...not sure if I follow...I tried the following from a second computer: 192.168.1.106/tfs/web and that worked, although I was surprisingly prompted for a usercode/password. I entered that which I used to log onto the web server. –  Chad May 23 '10 at 5:55
    
BTW, I fwd traffic for port 80 and 8080 to 192,168,1,106, the web server. –  Chad May 23 '10 at 5:56
    
FYI. I do not have a switch –  Chad May 23 '10 at 16:54
    
I take my first comment back. 192.168.1.106:8080/tfs/web works from the box that is 192.168.1.106, but doesnt work from another pc on my Home Network unless I turn off the firewall on 192.168.1.106. How do I change my firewall settings to allow traffic on 8080 but otherwise be on? I see where you allow exceptions on a by program basic. What would the program be? Is there an exe for IIS that I need to point to to grant the exception? –  Chad May 23 '10 at 22:00
    
Check out the screen shot I added showing my firewall settings. I think I disabled everything. –  Chad May 24 '10 at 1:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.