Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.
D:\svnroot>svn commit -m "Type your justification here" --username svnu --password test

svn: Authorization failed

I'm sure the username/password is correct(in conf/password),is it necessary to have exactly that user on the remote svn server?

share|improve this question
add comment

3 Answers 3

I'm sure the username/password is correct(in conf/password),is it necessary to have exactly that user on the remote svn server?

conf/password or conf/passwd? The correct file is passwd. As for having "exactly" that user on the remove SVN server... I don't know what you mean? The username has to be correct, but it doesn't need a user account.

Note that SVN is probably case sensitive when it comes to usernames and passwords.

share|improve this answer
    
Yes it's a typo,should be passwd,but even that doesn't work. –  user31450 May 23 '10 at 8:00
add comment
 __   __ _______ _______  
   \_/   |______ |______  
    |    |______ ______| .
share|improve this answer
add comment

Note that it says that authorization, not authentication, failed. Your username and password were accepted, but SVN doesn't think that that user has write permission.

Assuming you're using svnserve (since if it were apache the error would mention a HTTP status code):

  • check that svnserve wasn't started with the read-only option
  • check that svnserve.conf has auth-access = write
  • if an authz file is in use, check that it lists your user
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.