Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded the Ubuntu version 10 from the Internet and tried to run the wbu.exe inside the image that I burned to a CD. I am getting the following error:

enter image description here

My details:

  • OS: Windows 7 Ultimate
  • Processor: Core Quad i7
  • RAM: 4GB
  • Graphics Card: 1GB nVidia
share|improve this question
up vote 2 down vote accepted

Wubi is not for permanent installation. It's only for trying out. You don't need the whole ISO, here is the most recent installer for this. However, you should resize your partition and install Ubuntu to a free space if you want decent performance , no problems and so on. (You can do this by right clicking "Computer" in the Start menu (okay that orb), choose "Manage", "Storage", "Disk Management", and there right click on the given partition Shrink volume...)

(You have to burn out the ISO like you did AND reboot your computer AND boot from the disc. Like how you would install a Windows. Using that .exe will give you something else, an Ubuntu installed on your partiiton on the NTFS drive. (ntfs support is not the best, performance will be somewhat far and overall the spare partition is just better. Even updates can screw up this kind of install.))

share|improve this answer

For your use case, Ubuntu can be installed in two ways:

  1. Install as an image file in your existing Windows Drives.
  2. Install on a separate partition on your harddrive.

Do you want to go for option 1 or do you have disk space for option 2 and don't mind going for it? Wubi is only useful for the first case, and 1 is the easier option; the only downside will be a small performance degradation and your Linux installation being dependent on Windows.

share|improve this answer

Check your BIOS for a setting that stops the master boot record from being modified. If you can find one, ensure that it's set to allow master boot record changes and try again.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .