Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For serveral days now, a website isn't accessible on a single pc in the LAN. On the other pc's, it works just fine. And it's just a single website that's not accessible as far as I know of.

The website generates a timeout on every single web browser I've tried (IE8, Firefox and Chrome). However, traceroute, nmap and telnet all work just fine. I've even tried multiple user accounts and safe mode, but that didn't work either. As a side note: using a linux live cd did work and I could access the website without any problems.

The hosts file is the windows default, the ip- and dns settings on the network adapter normal as well. No strange processes are running and no viruses found.

According to tcpview and netstat there are connections to the domain, but every request in the browser results in a timeout.. Any idea what's happening?

Update: All of the computers on the network running Windows (any version) are showing this problem now. The website is still working under linux and mac osx. So, it has to be related to some kind of windows update (although I haven't installed any on one computer in the past week, which I've set to do manual updates only)..

share|improve this question
    
Are any of the other machines WinXP? –  Puddingfox May 23 '10 at 21:10
    
No, but I've tried virtual pcs with xp and I was able to access the site on those 'machines'.. –  DorentuZ May 23 '10 at 23:01
    
Have you tried going to that sites IP address directly? –  wag2639 May 24 '10 at 20:21
    
Yup, didn't work either. –  DorentuZ May 24 '10 at 22:26

3 Answers 3

You probably already tried these but just in case you didn't:

  • Check proxy settings in IE
  • Try accessing the site in safe-mode with networking
  • System restore to before this problems started
share|improve this answer
    
None of the browsers is using a proxy, already tried safe mode with networking and system restore is disabled. –  DorentuZ May 24 '10 at 22:26

Few ideas, hope one helps.

  1. You've tried with the IP address directly, and not using the domain name?

  2. You say telnet works just fine... what exactly do you mean by that? You can access the web server on port 80? (That'd be really weird!) If you can, can you try to do a manual HTTP get for the resource and let us know what happens?

  3. You can use something like TamperData for Firefox, or Microsoft Network Monitor to let us know where things are going wrong (if you can get a TCP connection going in the first place).

Basically I think what you need to do now is follow the route that the browser's taking to access the site, and verify each step is working ok. Given that it always works on the other machines, and never on the Win ones, it should be quite easy to find.

HTH

Andy

share|improve this answer
    
Tried both domain name and ip, none worked - in a webbrowser. The weird thing was, that when using a proxy through a linux pc in the network, it worked as it should. I gave up on this problem, since I worked around it (see reply to harrymc) –  DorentuZ Jul 23 '10 at 14:12

The problem is strange enough so that more information is required.
I suggest using the Fiddler2 Web Debugger to initiate the request to the website. This will tell you if the website is truly inaccessible, or just responding with an error.

In any case, since you say that the website works with XP, then the problem can be with a major feature that was introduced in newer Windows versions : TCP Receive Window Auto-Tuning.

From Disable TCP Auto-Tuning to Solve Slow Network :

Using an elevated command prompt :

Check the state or current setting of TCP Auto-Tuning :

netsh interface tcp show global

Disable TCP Auto-Tuning :

netsh interface tcp set global autotuning=disabled

Enable TCP Auto-Tuning :

netsh interface tcp set global autotuning=normal
share|improve this answer
    
It's been a while since I've looked at this thread, and I've kinda worked around this problem now by setting the modem/router to bridge the internet connection to another router on the network. The problem affected the XP computers only, at first. Later none (5 out of 5) of the windows computers were able to resolve the domain (no reply) - linux (even a livecd on a windows pc) and mac still worked fine. –  DorentuZ Jul 23 '10 at 14:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.