Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

On windows 7 (x64), the default option, for saving text files in notepad is ANSI. One can select other encoding from the combo box, however, I'd like this option to be the default.

share|improve this question

marked as duplicate by Dave M, ultrasawblade, Dave, and31415, Heptite Aug 7 at 5:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Here simplest fix - softpedia.com/get/System/OS-Enhancements/… (It will automatically associate UTF8 with Notepad. No need to install anything, just run once ) –  Solutioner Aug 5 at 6:48

2 Answers 2

Idea for saving it in UTF-8 by default, haven't found a different encoding way as default.

  1. Right click -> New -> Text Document
  2. Open "New Text Document.txt". Do NOT type anything!
  3. Go to "File -> Save As... " and choose UTF-8 under "Encoding:", press "Save" and overwrite existing file. Close the file.
  4. Rename "New Text Document.txt" to "TXTUTF-8.txt"
  5. Copy "TXTUTF-8.txt" to "C:\WINDOWS\SHELLNEW"
  6. Go to "Start -> Run..." and type regedit. Press OK.

  7. Navigate to "HKEY_CLASSES_ROOT.txt\ShellNew"

  8. Right click in the right window -> New -> "String Value" and rename it to "FileName"

  9. Double click on "FileName" and put "TXTUTF-8.txt" into "Value data:" field and press OK.

  10. It's finished.

  11. Test it: Create new .txt document (Right click -> New -> Text Document). Open it and go to "File -> Save As... " and see that encoding is set by default to UTF-8

share|improve this answer
1  
It accomplishes its purpose well, however, sometime, I find myself starting new file with no intentions of saving it, and ending up with something that I'd like to save. That's usually when I encounter that problem, and if I'm not careful enough when saving, it can destroy a document written in a foreign language... It's all a matter of habits, but I hoped there might be some way to change it permanently. –  akurtser May 24 '10 at 16:28
    
Is there any one-click solution? –  PHPst Oct 7 '12 at 8:55

In windows 7 (perhaps other systems as well) you need to set the system locale - regional settings > administrative tab > change system locale to the language of your choice. This solved my problem of Hebrew fonts not displaying properly in notepad.

share|improve this answer

protected by slhck Aug 21 '13 at 10:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.