Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This one's a bit of a stumper. I'm running XP SP3, current with all fixes, etc. My problem is that I can assign a drive letter to a container file (explained below), it works just fine. But once I close the container, the drive letter is no longer available until the next boot.

I've got some confidential data that I've placed in a container volume. I've used TrueCrypt (www.truecrypt.com) and FreeOTFE (www.freeotfe.org), with both installed and portable versions for both, with the same result. I open the container file, assign it to a drive letter (say R:), and run some portable apps that are within the volume. When I'm done, I close the container, and the drive letter is released. Fine so far. However, when I attempt to re-open it, the previous drive letter (in this case R:) is no longer available. It's not mapped to anything, it's just unavailable. Even attempting something like "subst R: C:\" returns "Invalid Parameter - R:". I can use the S: drive, no problem, but the next day I have to use T:, then U:, etc. Eventually, I have to reboot to reclaim all of of the drive letters.

Unfortunately, everything I've read about drive letters relates to USB assignments, which doesn't apply here. I've tried the "show hidden" command (set devmgr_show_nonpresent_devices=1) with no success. And the Disk Management tool doesn't apply either, since it's not a physical drive.

Does anyone know where Windows keeps the list of drive letters? And is there anything short of a reboot that can be used to reset it?

share|improve this question
add comment

2 Answers

Try registry editing... found here

http://www.mydigitallife.info/2007/11/08/change-or-delete-system-drive-letter-via-registry-to-remove-conflict-usb-or-firewire-drive-letter/

same principal. Sounds like your mount issues are not getting cleared up by your encryption application when you've finished them, so... that means to me that your not closing them correctly.

share|improve this answer
    
Thanks, but I'd already tried that one ;-) The drive letters don't appear as \DosDevices\. I also thought it was a problem with the encryption app shutting down, which is why I tried a second encryption app. They both behave the same. That's why I suspect it's an OS issue rather than an application issue. Thanks for the reply, I hadn't seen that particular link before. –  billdehaan May 24 '10 at 4:28
    
billdehaan, did you ever find a solution for this? I'm running into the exact same issue with TrueCrypt. –  Jason May 10 '11 at 18:24
add comment

From a command prompt, trying some of these commands

 MountVol
 Subst
 Net use

They might tell how the drive letter is allocated. They each should have a syntax to remove a reserved letter.

Note, I have never use the mountvol, so I would be cautious about doing this until you are sure this dismounts the volume cleanly and won't corrupt your data.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.