Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For a while now, my sound has not been working in Ubuntu. It used to play OK, but after some upgrade (might have been distro upgrade to 9.10), it stopped working. I'm currently running 10.04 on an amd64 architecture. I'm using the builtin audio on a Foxconn motherboard, it's an ATI / Intel HDA chip with an Azalia controller, apparently it's using the Realtek ALC1200 codec. All the gory details here. Edit: after reinstalling the audio packages, my config now looks like this (but still doesn't work).

I found a nice sound troubleshooting tutorial here, which is well-written and pretty extensive, however, I fail to look up the supported "models" for my soundcard.

The troubleshooting page says to look for a section giving the codec used by your soundcard, which looks like this for me:

!!HDA-Intel Codec information

Codec: Realtek ALC1200

Then, I'm supposed to lookup the models for that codec in the file Documentation/ALSA-Configuration.txt in the appropriate directory of ALSA's git repository. Mine actually pointed me to a separate file, Documentation/HD-Audio-Models.txt, which, for my driver version is located here and contains no section related to ALC1200 codecs.

I tried putting the driver options probe-mask=1 and model=auto in a config file for modprobe, as suggested elsewhere, but this just lead to snd-hda-intel not able to load at all anymore. I also tried installing the linux-backports-modules-alsa package for my kernel, because the description sounded promising, but that didn't change anything, either.

share|improve this question
Are you running alsa? I'm asking you that because since 9.04 pulseaudio is the default audio server and, unless you haven't already uninstalled it and replaced with alsa, you could do it now. – dag729 May 24 '10 at 11:15
@dag729 - I seem to have both installed, I sort of assumed that pulseaudio and alsa are sort of complementary? My primary audio device (in System Settings -> Multimedia) is pulseaudio, the second Intel HDA. – Hanno Fietz May 24 '10 at 11:39
up vote 0 down vote accepted

I followed the troubleshooting advice in this PulseAudio wiki, and was embarassed to find that my Master channel showed up as muted in alsamixer...

Unmuting it as such didn't help, but when I reset PulseAudio by stopping the daemon and removing all configuration and temporary files, as suggested on the above page, I got sound.

Now, I'm not sure which of the two was the fix, maybe both of them, but a muted Master certainly won't play sound, I guess...

share|improve this answer
Good! What matters is that now you got sound: anyway I think that restarting the daemon would be enough. (accept your answer, since you found the solution, no?) – dag729 May 24 '10 at 12:36
@dag729 - To accept your own answer, you need to wait two days. What I don't like about problems like this is that there a million possible solutions, it hardly makes sense to have a single answer. For future readers, a checklist would be much more helpful. – Hanno Fietz May 24 '10 at 15:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .