Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have atheros wifi hardware, intell chipset, gigabyte laptop and CentOS 5 installed.
Now I try to use wireless network and get problems.
First of all I want to say that I have 2 OS on my laptop, and when I load Windows XP I still may to access to the wireless network.

First I try to get it on Linux was to make active wlan0 interface in:
system -> administration -> network
but I get:
Determining IP information for wlan0... failed.

Second I try also was unsuccessfully:
[root 1 network-scripts]# ifup-wireless
Error : unrecognised wireless request "off"

This relevant output of iwconfig is:


Warning: Driver for device wlan0 recommend version 21 of Wireless Extension, but has been compiled with version 20, therefore some driver features may not be available...

wlan0 IEEE 802.11 ESSID:""
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7
RTS thr:off
Fragment thr=2352 B
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
{output not in the original format}


The same things are happen even if I do:
modprobe wlan0 (this not get error)
Important to say that modprobe not succeed to find ath_pci, tharefor I decide to download latest version of the madwifi driver from http://madwifi-project.org. I extracted this, but when I make this, this is what I get:


[root 1 madwifi-0.9.4]# make
/bin/sh: line 0: cd: /lib/modules/2.6.18-164.el5/build: No such file or directory
Makefile.inc:66: * /lib/modules/2.6.18-164.el5/build is missing, please set KERNELPATH. Stop.


I tried to set KERNELPATH, but I think that it was incorrect:


[root 1 madwifi-0.9.4]# make KERNELPATH=/lib/modules/2.6.18-164.el5/kernel/
/bin/sh: cc: command not found
Makefile.inc:81: * Cannot detect kernel version - please check compiler and KERNELPATH. Stop.


Some one have any ideas?
Thank you very much for ahead.

share|improve this question
    
So, like I understand, for compile I need to install Development Tools group first, but can someone say what KERNELPATH must be set to? –  Rodnower May 25 '10 at 20:11
    
So I found good resource: soad1982.blogspot.com/2009/05/…, here is described about wifi configurations, but when I set password, I get: Error for wireless request "Set Encode" (8B2A) SET failed on device wlan0 ; Invalid argument. Any one know what is wrong? –  Rodnower May 25 '10 at 21:27
    
If this will help there is file with CentOS getinfo.sh output (include lspci output): 4shared.com/document/PiClBpLY/getinfouot.html –  Rodnower May 26 '10 at 17:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.