Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to enable anonymous access to a single service in my Samba config. Authorized user access is working perfectly, but when I attempt a no-password connection, I get this message:

Anonymous login successful
Domain=[...] OS=[Unix] Server=[Samba
3.3.8-0.51.el5] tree connect failed: NT_STATUS_LOGON_FAILURE

The message log shows this error:

... smbd[21262]: [2010/05/24 21:26:39,  0] smbd/service.c:make_connection_snum(1004)
... smbd[21262]:   Can't become connected user!

The smb.conf is configured thusly:

[global]
   security = ads
   obey pam restrictions = Yes
   winbind enum users = Yes
   winbind enum groups = Yes
   winbind use default domain = true
   valid users = "@domain admins", "@domain users"
   guest account = nobody
   map to guest = Bad User

[evilshare]
   path = /evil/share
   guest ok = yes
   read only = No
   browseable = No

Given that I have 'map to guest = Bad User' and 'guest ok' specified, I don't understand why it is trying to "become connected user". Should it not be trying to "become guest user"?

share|improve this question
    
Which version of Samba are you using? Which type of Windows(?) client is trying to access your Samba? – Kurt Pfeifle Jul 29 '10 at 23:07

Check out this tutorial

You remembered to restart samba to pull the config also what are the local permissions for that folder?

share|improve this answer
    
Can you copy and paste the information from that link? It helps prevent link rot – Canadian Luke May 26 '12 at 3:22
    
that tutorial should not be used - "security = share" is deprecated, see my blog post : blog.realcomputerguy.com/2010/12/… – user168261 Apr 19 '13 at 14:01

remove

valid users = "@domain admins", "@domain users"

from [global], only use it in shares that are not "guest" enabled

share|improve this answer

protected by JakeGould Oct 12 '15 at 20:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.