Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use alsa, and I don't have a volume control applet on my Gnome Panel.

When I right click and select "add to panel", there is nothing that has to do with "sound", "audio" or "volume" in the list, and the "Indicator Applet" or "Indicator Applet Session" things have no volume controls, or properties that would let you enable any sort of volume control.

How can I get a volume control in Ubuntu, so I don't have to run aumix in a terminal or something?

So I've got the thing working now. But does anyone know why the new, fancy "Indicator Applet" volume control doesn't appear? The Gnome Volume Control Applet isn't as nicely featured, although it actually works.

I've been using Linux since Redhat 5, it's beyond me why these sorts of problems are still around. Someone should just put a damn "Volume Control" element in the list of things to add to the panel, even if it doesn't work, perhaps showing an error message.

share|improve this question
    
One of the changes in 10.04 is a rearrangement of the way the panel works. See page 2 of this review. –  Dennis Williamson May 25 '10 at 5:00

5 Answers 5

up vote 28 down vote accepted

Click on System > Preferences > Startup Applications. When that loads, click on Add, then add the following:

  • Name: Volume control
  • Command: gnome-sound-applet
  • Comment: Launch volume control applet

That will launch the applet every time you start up and give you the icon in the notification area.

share|improve this answer
    
This is the most complete answer. I actually found this in a forum as well. –  Neil May 26 '10 at 15:48
3  
Just upgraded from 11.10 to 12.04, the executable is now called gnome-sound-applet. –  Martin Foot Aug 16 '12 at 9:32

The volume control is no longer a panel applet. It now sits in the system tray. Run gnome-volume-control-applet to start it.

share|improve this answer
    
This works, but only when you use pulseaudio, which makes my speakers pop, but I can live with that for now. Maybe some day pulseaudio won't be crap. –  Neil May 26 '10 at 15:47

This worked for me:

Source: http://www.virtualhelp.me/linux/107-volume-controlicon-is-gone-ubuntu-1004

  1. Right-click on the panel where you'd like the volume controller to appear and select "Add to panel"
  2. Choose "Indicator Applet" from the list and click on "Add" and you're done.

The volume control should be back.

share|improve this answer

Right Click on the Panel >> Click Add to Panel >> Search Indicator Applet >> Click Add then Close the window. Now You will get the volume indicator on the panel.

share|improve this answer

Just add the indicator applet and this should solve the problem.

You are right that the Gnome Volume Control is nothing like the one you have with the indicator applet.

share|improve this answer
1  
This just shows you an email icon, and some other irrelevant things. It's useless in the context of volume control. –  Neil Feb 2 '11 at 17:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.