Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am working on a Win 7 Ultimate machine, and was using XP for some development tasks (for compatibility checks). Everything worked like a charm on the XP, including updates.

Two days ago I had to switch computer (mainly a new motherboard/cpu), and I had just stuck my old HD inside the newer case. Win 7 worked like a charm - installed all the new drivers, identified everything automatically, no sweat. The trouble started when I tried running my old XP mode - it won't launch, complaining about the cpu change. I figured it's not a big deal, and I deleted the VM, and re-ran XP mode. It told me it can't find it, and offered to create a new one, just what I wanted.
I had finished setting up the new XP mode VM, and it seems to work just fine. Got it to use the host network adapter, so I can surf from "inside". But I can't get Windows Update to run. Whenever I click on the "Custom" button on the WU site, after a short while, I get the [Error number: 0x80072EFD] page.

I tried several solution from around the web for it (clearing some cache and restarting the wuauserv, even a microsoft fix-it run), but still nothing seems to work.

Anyone here has any new tips for me? Thanks.

share|improve this question
add comment

2 Answers

This error just means no connection possible to the Windows Update site.

This Microsoft article lists some more points to verify:
You may encounter temporary connection-related errors when you use Windows Update or Microsoft Update to install updates

Another possibly useful article discusses limitations that Windows Update places on XP Mode:
Windows XP Mode Internals – Part 2 (Application Publishing Magic)
(use with caution)

share|improve this answer
    
Thanks for offering your help, but I have already tried the fixes offered by MS over there. And I don't understand the 2nd link. My previous XP Mode VM updated itself without any problem or special hack... –  Noam Gal May 26 '10 at 10:41
    
@Noam Gal: I would guess that something went wrong with deleting the XP VM, maybe because of a Microsoft bug. Perhaps you should uninstall XP Mode and restart from scratch. See blogs.msdn.com/b/zxue/archive/2010/01/27/… and also technet.microsoft.com/en-us/library/ee431673%28WS.10%29.aspx. –  harrymc May 26 '10 at 12:32
add comment
up vote 0 down vote accepted

It took several tries, but I got it to work -
I had no luck with removing and reinstalling the XP Mode. Got the same problem when trying to run Windows Update. Surfing the web worked just fine from the VM.
I then updated manually to IE8, and after a reboot of the VM, couldn't even surf at all. I fiddled around the IE Connection Settings, unticked the "Automatically Detect Settings" in the Lan Settings dialog, and had internet again, while being able to use Windows Update!
It might even have worked on the original IE6 - worth a shot if anyone is stuck with a similar problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.