Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Currently I am trying to run VirtualBox on my second monitor, with a dedicated mouse and keyboard. However, doing so has not proven easy. There has been times where the mouse works, but not the keyboard, vice versa, or nothing works at all. The biggest problem I am running into is this:

When enabling the USB mouse and keyboard from the VM, I get an error: 'USB Device is busy with a previous request.' The only thing that is using second mouse and keyboard, however, is Windows. The other error I have received stated that the VM was unable to create a proxy for the device. Additionally, the VM occasionally will disable the secondary keyboard entirely, requiring me to unplug and replug it into my PC to re-enable it again.

Keyboard auto-capture is disabled, and while a solution I was reading online stated to turn off mouse integration, that option is grayed out on my machine.

share|improve this question
1  
+1 Interesting problem –  Nifle May 25 '10 at 7:20
    
+1 I'm related to you –  Carson Myers May 25 '10 at 7:39
    
Not sure it's possible to isolate 2 sets of input devices on 1 physical machine but most definitely 1 for Interesting Problem –  BearGriz72 May 25 '10 at 20:48
    
it's possible, we got it working. I'd post a solution as to how, but it happened by magic. It just... sort of... started working. –  Carson Myers May 26 '10 at 1:10
    
Did you try using VMware player Myersguy? –  Shiki May 26 '10 at 10:25

3 Answers 3

I had the same error (and a few others!) when I was trying to get VirtualBox to capture my iPhone in a Windows VM. The solution for me was to create a USB Device Filter for that particular VM.

  1. The VM must be in a "Powered Off" state
  2. Select the VM in the VirtualBox GUI
  3. Click the "Settings" button
  4. Go to the menu item "USB" (in here you can add/delete/edit USB Device Filters)
  5. On the right-hand side, click the button "Add Filter From Device" and it will list the connected and detected USB devices
  6. Select your keyboard from the list
  7. Add another filter for your USB mouse
  8. Start your VM and hope it works :)

When I did this for my iPhone, when the (virtual) operating system booted up it detected my iPhone straight away and I could sync with iTunes in the VM. The host didn't detect the iPhone until I manually disconnected it from the VM.

share|improve this answer

You might also experiment with Synergy application to connect the keyboard (and clipboard) virtually over tcp/ip. You might need to visit the advanced settings in Synergy, unless you have complete DNS setup for your machines.

share|improve this answer

Try convincing the host OS that it can't recognise the seccond keyboard and mouse. That should leave them open for the guest to grab via a USB rule.

share|improve this answer
    
any suggestions on how to do that? –  UncleZeiv Nov 23 '10 at 0:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.