Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I try to get the Windows 7 (or Vista) remote assistance feature to work, without using UPnP on the novices computer.

After enabling Teredo on the expert's computer (that is in a corporate network, and therefore has teredo disabled by default), I tried to connect to the novice both using Easy Connect and the invitation file with no success.

My triubleshooting included the following (so far).

  • A connection to the novice from my home pc was successful, hinting at a misconfiguration on the experts side.
  • Both computers have a "qualified" connection to the Teredo Server.
  • Both computers have a valid Teredo IP, access to the Global_ PNRP cloud and can resolve names registered with PNRP on the other computer.
  • The expert can resolve the PNRP Id automatically generated with an Easy Connect help request
  • Both computers can ping the other's PNRP name.
  • Both computers can ping the other's Teredo IP Address using ping -6

Now, I am a little stumped. I expected Remote Assistance to work at this point, since my corporate firewall has no Teredo filtering. What could RA cause not to work in this setting?

Thanks in advance!

share|improve this question
    
I'm running windows 7. My remote desktop is set up to use port 3389 by default... and so is every other windows computer. You can check to see what port your computers are configured with in the registry: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\R‌​DP-Tcp\PortNumber Just convert the hex over to decimal... It'll probably be 3389. –  James T Jun 4 '10 at 7:19
add comment

2 Answers

You can try to telnet the novice IP address from the experts computer at port 3389 as described by Microsoft to see if that port is accessible. If it is not accessible... then I would expect that a firewall between the expert and the novice is blocking port 3389.

http://support.microsoft.com/kb/187628

You can use the escape character ctrl-] to break out of the hung session.

Port 3389 needs to be accessible in order for it to work. See article below:

http://technet.microsoft.com/en-us/library/bb456978.aspx

Edit: Note that windows live messenger has an option to connect using live assistance without having to open up any ports... however I have found this to be very flaky. Microsoft's SharedView is a good option if you want a remote assistance option without opening ports. I have also heard that TeamViewer is good.

http://www.ehow.com/how_5331830_use-windows-live-instant-messenger.html

Sorry for spewing out so many different answers. My way of finding solutions is usually a brain storm kind of thing.

Another thing to check would be under "system" in control panel and then in "advanced system settings" and then in the "Remote" tab under "remote assistance" click on Advanced and see if the check box that says "create invitations that can only be used from computers running windows vista or later" is checked.

share|improve this answer
    
Indeed, if the novice is using XP the port will be 3389 –  Pulse Jun 3 '10 at 5:50
    
Thanks, but this information relates to Windows XP. Both of my test computers run Windows 7. I tested Vista, too. –  Jens Jun 4 '10 at 6:56
add comment

Not sure is this will help but, using the scenario you described above, in addition to the configuration you already have, requires UDP traffic to be allowed, either through a NAT and/or a firewall at the novice computers end.

If I remember correctly, Win 7 to Win 7 and Win 7 to Vista, RA connections use dynamic ports 49152 - 65535.

If you're using the Win 7 firewall on the novice machine you need to check which profile you're using, also.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.