Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to use dual monitors with remote desktop on windows 7 ultimate. Host machine is win server 2008 r2. I open the run window type mstsc /multimon and press enter, also "use all my monitors for the remote session" is checked.By this way RDC is opening but only in one monitor.Do I need to do any changes on host too? I have tried /span attribute and it worked but I don't want it.

share|improve this question
    
I'm having this exact problem from a windows xp client using mstsc 7.0. I see your question hasn't been answered since May of 2010 so I'm losing hope :-D – Pandincus Apr 7 '11 at 2:43
    
I am working with 5 remote servers and only one of them supports multi monitor usage. All of them have win 2008 r2. I think the hardware must support multi monitor otherwise nothing to do with that. But in the other hand the server that supports multi monitor has the most basic hardware. – zforx Apr 7 '11 at 13:38

Does the server have multiple monitor support enabled? According to this article, you can find this setting in Remote Desktop Configuration → RDP-Tcp → Client Settings, then here you set the maximum number of monitors per session (it may be set to 1 currently). There are also two group policies listed in that article that control the number and resolution of monitors allowed.

share|improve this answer
    
I have looked that article and tried every method mentioned there but none of them worked. (except changing Win32_TSClientSetting) – zforx Apr 18 '11 at 7:18

The Server [ or the computer you are connecting to] has to be either Windows 7 Ultimate or Enterprise. Only those 2 will allow the use of the multimon switch.

share|improve this answer
    
What about Windows Server 2008 R2? – RredCat Aug 29 '12 at 14:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .