Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just stuck in a new 64 GB SSD (literally out of the box) into my Lenovo X61 laptop, replacing an old 5400 RPM 80 GB drive. When I boot the system, my motherboard successfully sees the SATA hard drive.

Now I want to install Ubuntu on it. I stick it in the CD drive, bootup the system, and it gets to step 4 (choose partition), but sees no available partitions. Do I need to do something to the hard drive before installing Ubuntu?

Many thanks.

Edit: Also, I just ran the hard disk drive diagnostics program that came with the BIOS, and it checked out 100% good. Not sure what to make of this.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Try running this from a terminal:
sudo apt-get update
sudo apt-get install gparted
sudo gparted

And here you can see whats happenin', create a new partition table if needed. Try creating the partitions here. (Yes, do this from the LiveCD)

share|improve this answer
    
the LiveCD should already have gparted available if you've booted into the LiveCD desktop environment. it's in the System -> Administration menu. gparted is not included in the default install, so in a fresh installation you will have to install it. –  quack quixote May 25 '10 at 22:06
    
Thanks, this worked perfectly! –  ash May 26 '10 at 0:17
    
Sorry last time I couldn't find it, had to install it and it wasn't installed at all (9.10, 10.04) :/ –  Shiki May 26 '10 at 6:12
add comment

I had the identical problem. Neither gparted nor fdisk showed the drive. I had to eventually do this:

Solution: I had to mess with integrated peripheral settings in BIOS. The mobo's default setting for all the sata ports including [drive in question] were IDE. Unfortunately this hard drive only works with RAID or AHCI (I opted for the latter). You have to go under integrated peripherals -> on chip settings -> And switch the [drive] from IDE (the default setting) to RAID or AHCI.

From here http://ubuntuforums.org/showthread.php?t=1822085

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.