Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After patching some kernel modules, I got VMware Workstation 6.5.4 running on my Ubuntu 10.4 x86_64 machine. However, now my Windows XP SP3 guest instance cannot keep mouse input captured for any length of time. I can sometimes activate a control in the guest if a double click very quickly, but it's not reliable (and extremely annoying).

Everything appears to be fine in Unity; the problem just appears when I'm running the instance in the VMware window.

share|improve this question

I believe I solved the problem. In essence, you have to tell VMware to use the shipped version of GTK by setting the value of the VMWARE_USE_SHIPPED_GTK environment variable to "yes". I added the following line to my /usr/bin/vmware script:

export VMWARE_USE_SHIPPED_GTK=yes

I found the technique here: http://blog.creonfx.com/linux/vmware-player-workstation-mouse-grab-input-focus-bug

share|improve this answer

You must log in to answer this question.