Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Right now, when I right-click on a PNG or JPG, I get the Edit context menu which takes me to MSPaint. How can I associate the Paint.NET with the Edit menu?

I've tried Tools/Folder Options/File Types, but I don't really see anything there.

alt text

Note that it says to click Advanced, but I don't see the Advanced button. Also, the caption does not even refer to the right file type, so something is clearly corrupted. I am seeing the same issue with the JPG entry.

share|improve this question

marked as duplicate by techie007, Tog, Kevin Panko, Marcks Thomas, Shakehar Mar 16 at 19:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer

up vote 2 down vote accepted

Tools > Folder Options > File Types is the right place.

Find JPG/PNG in the list of extensions and then you'll see the Details for 'JPG/PNG' extension filled in below.

There's an "Open's with" label and icon + a button marked "Change...". This is for opening/viewing. Click on the "Advanced" button to get a dialog for the different options - edit, open and printto.

Select "edit" then the "Edit..." button. Browse to MSPaint. Don't forget to ensure that there's the "%1" (including quotes) after the exe to ensure that the file gets passed correctly.

share|improve this answer
    
I added more details - also I don't see the Advanced button. –  AngryHacker May 26 '10 at 16:46
    
That's strange. Where you have a button that says Restore, it should say Advanced instead. –  BBlake May 26 '10 at 16:50
    
@AngryHacker - Where you have a button that says Restore, it should say Advanced (from @BBLake's comment). Interestingly the text refers to "P10" rather than "PNG". I think clicking "Restore" should be safe. You could try it and see if it changes to "Advanced". –  ChrisF May 26 '10 at 17:05
    
Yes, I fixed it. I clicked on Restore for the JPG and the button changed to Advanced. I went into it and the Edit entry was missing, even though, it was still in the context menu. I entered a new Edit entry, which fixed it. Oddly enough, it also fixed the Edit association for the PNG as well, even though I did not mess with it at all. The PNG File Types entry still has the Restore button. –  AngryHacker May 26 '10 at 17:08
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.