Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I browse web pages in Internet Explorer, especially AJAX heavy sites, IE constantly clicks at me. How do I stop the madness?

share|improve this question

migrated from serverfault.com May 26 '10 at 23:16

This question came from our site for professional system and network administrators.

4 Answers 4

up vote 16 down vote accepted

If you don't want to hack the registry:

Go to Control Panel > "Sounds and Audio Devices".

Select the "Sounds" tab.

Scroll down to the "Windows Explorer" section:

Set the following sounds to (None):

  • "Complete Navigation"
  • "Start Navigation"
share|improve this answer
1  
Is this action equivalent to other answers posted, including the accepted answer? If so, kudos (+1) to you for a solution that is usable "for the rest of us." (Can you imagine trying to explain how to use the Registry Editor to an average, non-technical user?) –  Danny Whitt Oct 26 '09 at 9:54

You need to disable the "Start Navigation" sound that is part of the Explorer shell. Disabling this sound will disable it for both Internet Explorer AND the Windows Shell.

You can do this via a simple registry key change as well. Create a file called Disable Start Navigation Sound.reg and place the following contents:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\Explorer\Navigating\.Current]
@=""
share|improve this answer
2  
This is usually the first thing I do on any new Windows installation. Likewise turning off key clicks on iPhones... –  Jon Skeet Apr 30 '09 at 21:11
    
+1 for that. People on trains who leave the key clicks switched on for their phones drive me mental! –  GAThrawn Oct 26 '09 at 13:32

This disables windows navigation sounds, I think it might work for IE also:

[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\Explorer\Navigating\.default]
@=" "
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\Explorer\Navigating\.current]
@=" "
share|improve this answer

XP:

Go to 'Control Panel' Double-click on the 'Sounds and Audio Devices' control panel Click the Sounds tab. Scroll down in the 'Program events' list until you find the 'Windows' section, then highlight 'Default Beep.' Change the 'Sounds' drop down menu at the bottom of the dialog to '(None).' Press the OK button when done.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.