Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When using Skype, it prevents the computer from idling, going into sleep mode and turning the monitor off.

I notice on my laptop if I use a tool like Monitor Off to manually turn my monitor off, after about a minute, the monitor will come back on as if Skype has pressed a key or moved my mouse to exit out of that idle state. This also prevents other programs (such as Pidgin) from going idle as well, so it looks like I'm online 24/7... even though it should be changing after 5 minutes of inactivity.

Is there a way to circumvent this behavior in Skype?

I think I've forgotten to mention a very important aspect: I'm using the video call feature pretty much 24/7.

It may be built into Skype this way, because on a video call, the participants are likely to be both voice chatting and watching each other, thus not doing any keyboard/mouse movement. That would make perfect sense. However, I would at least like some documentation stating this behavior and if there's any way to prevent it from happening.

share|improve this question
    
Well.. if one would use the video call and the computer would go idle/sleep.... guess all the consumers would be really pissed (count me in). If I use it (so yeah if video call works), it should NOT go into sleep. –  Shiki Jun 13 '10 at 13:42
    
I might be missing something here, but if you have a call in progress, why would you want the computer to sleep? Or is it just monitor-blanking you want, while keeping the camera active? –  JRobert Jun 13 '10 at 16:34
    
It's not so much I want the computer to sleep, it's more like I want Pidgin and a few other programs that use keyboard/mouse input for idle time to actually idle. Blanking the monitor is a problem given that I'm on a laptop and thus the only time the monitor is "off" is either in sleep or powered down. –  Corey Jun 13 '10 at 20:07
    
If I understand correctly, you want one app, Skype, to consider you still active (which I guess it is doing) and other ones consider you to be idle? I think you'll need a helper applescript (f/ex) to interpret whatever conditions you consider to mean "idleness" (f/ex, Skype in a call, but mouse and keyboard not used in 60 sec.) and tell Pidgin &c to change your status accordingly. Otherwise, aren't you seeking contradictory interpretations by different apps? –  JRobert Jun 13 '10 at 20:18
    
Skype's behavior is not dictated by whether or not you're idle. It simply prevents you from idling as to not dim the display in a video call. –  Corey Jun 13 '10 at 21:02

4 Answers 4

up vote 3 down vote accepted

You could work around this issue by quitting Skype when you are away. You should also shut your computer down every now and then to prevent it from over-heating (newsflash, sorry).

This seems like a silly solution, but I always try to re-install software that isn't behaving as expected.

EDIT: Skype won't go idle if you are on a video call 24/7, like you said. I found a link to their Issue Tracking and Reporting System, but it seems to be down atm.. Maybe you will have better luck with it later: link (note the https)

share|improve this answer
    
has a point, you should try reinstalling software that doesn't behaved like it should...+1 –  studiohack Jun 13 '10 at 1:44
    
I have reinstalled Skype, I'm on the newest version, and the problem happens when I'm in a video call. I have edited my question to reflect this. It was an important detail that I completely overlooked; my apologies. –  Corey Jun 13 '10 at 7:16

make sure your auto idle time is set lower then the time it will take your computer to sleep

share|improve this answer

I use Skype some, and have my computer (Windows 7) to automatically blank out after X number of minutes. I leave Skype minimized to the tray, and it doesn't give me any problems when the screen goes to blank out...

Just a suggestion, but I would try going to the Start Menu, typing "skype" in the search box, then right-clicking the Skype result that pops up, select properties, then go to the compatibility tab. Check the box that says "Run in Compatibility Mode" and from the drop-down menu, select "Windows Vista Service Pack 2". Click OK, and see what happens, if that fixes your problem... :)

share|improve this answer
1  
It works as it should when I'm not using Skype and have it minimized... The problem is that I have video call, webcam on, which is the issue. This is a very important detail I overlooked and edited my question for this. My apologies. –  Corey Jun 13 '10 at 7:15

Use the command "powercfg -energy" to see if any device is not entering suspend state.
This is probably the case with your webcam.

This and more is explained in the article
Troubleshoot Windows 7 Does Not Go Into Sleep Mode.

share|improve this answer
    
Typing and testing "powercfg" in itself defeats what I'm trying to test, which is idle time, measured from inactivity of the keyboard and mouse. I did try other tips on that page and none of them really worked. –  Corey Jun 17 '10 at 2:38
    
Corey Sarnia: powercfg will give a report on what WILL happen during sleep, power-wise. It's used to get concise report of your power settings. –  harrymc Jun 17 '10 at 5:19
    
Corey Sarnia: You should do "powercfg -energy > file.txt" and add to your post the section regarding the webcam. –  harrymc Jun 17 '10 at 6:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.