Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've used TestDisk and it's written my old partition structure of a ~20GiB partition for Vista, ~25GiB partition for 7 (but it now shows up as unallocated) and a ~400GiB partition for documents.

What it's meant to be is a 30GiB partition for 7, some unallocated space, and a ~400GiB partition for documents.

So currently, I have access to all my documents, but not any of the programs I've installed on C:, or AppData, because my boot partition is now supposedly a 20GB vista partition.

I've tried using my Windows 7 install disc's repair function, but that did nothing beyond wasting about 10 minutes of my time.

I'm currently posting from an Ubuntu live CD.

Any help?

share|improve this question

2 Answers 2

I heard there's a great program for fixing this, it's called TestDisk.

http://www.cgsecurity.org/wiki/TestDisk

TestDisk is a powerful free data recovery software! It was primarily designed to help recover lost partitions and/or make non-booting disks bootable again when these symptoms are caused by faulty software, certain types of viruses or human error (such as accidentally deleting a Partition Table). Partition table recovery using TestDisk is really easy.

share|improve this answer
    
Did you read anything other than the title..? –  unrelativity May 27 '10 at 10:41
    
Yeah I read the part where you used TestDisk. It's called sarcasm, buddy. –  ta.speot.is May 27 '10 at 10:46
up vote 0 down vote accepted

Panic mode does wonderful things to your train of thought.

After carefully rereading the TestDisk Step-by-Step tutorial, I noted a "Deeper Scan" option, which worked a treat.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.