Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Why has the appearence of NoScript changed?

Using Noscript in Firefox (Microsoft Windows):

Until now there has been an icon (the S icon) in the lower right of the screen. But now there is an button instead with the text "Options". Left clicking this button seems to bring up the menu as right clicking the old icon.

Can I restore the previous state?

Is there an auto-update function in NoScript and if so could it have caused the change? If it exists can the auto-update function be disabled?


Platform: Firefox 3.0.6, NoScript 1.9.0.6, Windows XP 64 bit, 8 GB RAM.

share|improve this question
    
sounds odd. Try update NoScript? think there are newer version than 1.9.0.6 (got 1.9.7 myself) –  Joakim Elofsson Jul 28 '09 at 19:09
add comment

7 Answers 7

up vote 2 down vote accepted

This happened because the Status Bar was disabled. Solution: use menu View/Status Bar to enable it.

share|improve this answer
add comment

As for how it happened, Firefox has an option to search for updates to your addons automatically. Do you have this selected? It is under Options->Advanced->Update.

As for whether you should worry: no. Does it all still work? If so, then you'll get used to the UI change soon enough. If there seems to be some functionality missing, try going to the NoScript website and looking at the release notes for that version.

Changing it back: there may be a setting in NoScript that will show the icon again. You'll have to find that yourself (if it exists). You could also uninstall the addon and reinstall an older version (can probably find old versions on the website). Is this recommended? No. Generally updates are done for a reason, and a UI change is often not worth going back a version over.

share|improve this answer
    
I have all updates turned off. In any case it is good to know where to look for these settings. –  Peter Mortensen Jul 28 '09 at 21:22
add comment

Firefox by default checks for plugin updates automatically, and then let you choose if you want to download and install them. As far as I can tell there is no automatic update without user interaction.

You can disable this check in the browser settings.

share|improve this answer
add comment

I had the same issue--no script icon had disappeared and wouldn't reinstall. The solution was to uninstall "McAfee SiteAdvisor". Once I went to Control Panel-->Programs-->Uninstall Mcafee Sitadvisor, Firefox restarted and Noscript was back.

share|improve this answer
add comment

In Firefox4 the solution is to look under the View menu and click Toolbars then click Add-on bar.

share|improve this answer
add comment

If we are talking about the same icon, for me it went from the addon toolbar to the navigation bar.

I went to "Views -> Toolbars -> Customise" (or similar, have a German interface here) and then I moved the icon by dragging it from the navigation bar down to the addon bar.

share|improve this answer
add comment

I had this happen to me around the same time; Firefox got into a funny situation whereby it kept asking me to reboot to apply the updated NoScript extension. But after each reboot I was told I needed to reboot again.

I also had my NoScript icon disappear from the browser. Was rather frustrating.

Eventually, I forget what I did, but somehow I broke the cycle. It might have even involved me closing the browser and starting it again. There was definitely something buggy about the NoScript update, though.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.