Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got two computers here that need to connect via wireless-g usb adapter to the same network for internet access but only one USB adapter. Both PCs are using Windows XP, and I have no crossover cables. I've got both computers wired up to a router, and the PC with the active internet connection has ICS enabled, but the second PC gets no internet. Any ideas?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Getting very confused here.

Are you saying that you are using the router as a switch and getting the internet connection via wireless on one of the machines?

If the above is true, and ICS is set up correctly (selected wireless as your connection and shared over wired), do either of the following:

On the other machine (not the one sharing), go to network settings and manually change the IP to anything in the same range as the ICS machine - but make sure that the default gateway is set to the ip of the ICS machine.

Or, try going in to the router and disable DHCP so that the ICS machine can apply the correct settings to the other machine.

If I have got it wrong here, please can you change your question to be a little clearer on your network topology!

share|improve this answer
    
Turning off DHCP on the router is probably the key. Also make sure both machines are pulled into LAN ports on the router, so you can be sure it's simply bridging between the two, not trying to do NAT. You might not even need the router or crossover cables. Auto-crossover (auto-MDI-X) PHYs have become common on Ethernet ports in my experience. (Then again, I tend to buy quality gear.) –  Spiff May 27 '10 at 15:38
    
Yup, thats what fixed it, I had to turn off DHCP ont he router so that the ICS machine could properly set the IP on the client. –  cornjuliox May 29 '10 at 0:51
1  
Just to clarify, I WAS trying to use the router as a switch and the ICS 'host' connects to the internet via wireless. –  cornjuliox May 29 '10 at 0:52
    
+1 @cornjuliox glad I could help! –  William Hilsum May 29 '10 at 1:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.