Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently bought an MicroSD card online. It's a Sandisk 16GB class 2.

However, it has a nasty problem. Every time I fill it with my data, the fat tables get corrupted. I've tried reformatting it, blanking it, doesn't seem to solve the problem. I have tried windows and linux (ubuntu), both have the problem. I've used my usb microsd readers, and even tried putting it in my phone and putting data on it from there. All have this problem.

Now the really odd thing is, besides the corrupted file tables, no programs can find anything wrong with the hardware. I've tried both chkdisk and "badblocks -w", neither give any type of error.

Now I don't know if the actual data gets corrupted, or if its just filesystem tables. What happens is that one or more folders start showing a load of chinese-charred (random UTF8 symbols I suppose) folders and files, and it is impossible to do anything with those. All the other data (outside of the corrupted folders) seems fine. I've tried to test it, and the problem doesn't seem to show up until I fill the disk upto about 3~4GB. After that I can still access the data. But as soon as I eject/safely remove/unmount it, the bad things happen somehow. Next time I plug it in, the folders I most recently wrote to (but sometimes also the folders I wrote the time before last time to) are all gibberish.

Does anybody have any clue what might be going on here?

EDIT: It seems I can't even put ext3 or ext4 on it, they both complain about a corrupted journal. Gheh, guess something is really broken here.

share|improve this question

1 Answer 1

You could have a defective card, Where did you get your memory card from?

I know for a fact that there are MANY copy/unbranded units that are defective and/or slower (e.g. selling class 2/slow cards as high speed/class 8) being sold as counterfit goods on eBay and some less scrupulous shops.

Even if it isn't counterfit, there is always the chance that you just got a dodgy unit! If you have never had this issue before on any other card, I would take it back and get another one as there must be an error with it.

If however you have had this issue before, it may be worth trying to use a memory checker on your machine(s), however I do find this unlikely. I would recommend memtest86+ for this.

share|improve this answer
    
A defective card, yet badblocks finds no errors on all 4 runs, seems unlikely to me. –  user163365 May 27 '10 at 19:19
1  
@ChaosR And yet you are having corruption... Just because you are not able to find bad blocks does not mean there isn't another problem e.g. the controller chip. –  William Hilsum May 27 '10 at 19:39
3  
Agreeing with @William, the problem is likely in the controller chip, not the actual Flash RAM. And you should return it if possible. –  CarlF Sep 9 '11 at 15:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.