Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using an Ubuntu box with Nvidia graphics card as an HTPC. My HDTV is a Sony Bravia KDS-R50XBR1; this is a rear-projection unit with many inputs. I am using the HDMI input. I'm using the proprietary Nvidia drivers and they recognize the 1080x1920 resolution just fine.

The display is a little fuzzy but at 50 inches it's perfect for movies. My problem is that the TV has three overscan settings, and none of them reduces overscan to zero. When I was using dual-screen this was fine, but I'm moving to where the TV is my only screen, and the Gnome panels are not visible because of the overscan.

EDIT: The menu in question is Settings::Screen::Display Area and the options are Normal, -1, and -2. The Normal setting has significant overscan, and the -1 and -2 settings make the overscan even worse.

I'd like to figure out how to eliminate the overscan, without trying to scale my 1080p content down to 920p or something ridiculous like that. Ideally there would be some scurvy trick, perhaps involving the TV service menu, to get rid of the overscan on the TV side. Or I could move the Gnome panels, but I still would be missing the edges of my movies. Suggestions most welcome.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

It took me ages and trying a vga cable sucessfully until I found the overscan compensation slider quite far down the list in the NVIDIA controls

share|improve this answer
    
Indeed, newer versions of the Nvidia driver provide this slider. The version current in May 2010 did not. –  Norman Ramsey Aug 7 '12 at 16:27
add comment

The Sony TV may have a non-obvious setting called "Display Area" that you can change: Go to "Settings" / Set-up / Screen settings / Display Area" and select the "Full pixel"

If you tv has no such setting you might try the settings in Ubuntu. Here's a page with some info on that: http://www.ypass.net/blog/2009/07/dvi-to-hdmi-overscan-screen-edge-cutoff-on-an-hdtv/

share|improve this answer
    
I've already tried the 'Display Area' menu with no luck. My bad for not making that explicit. Regarding Ubuntu, I want no part of X modelines. Been there, done that, bought the T-shirt, will never do it again. But it looks like if I upgrade to Ubuntu 10.4, the newer Nvidia driver may have overscan compensation. Regardless, for forcing me to improve the question, +1 –  Norman Ramsey May 28 '10 at 3:31
    
Norman -- Sorry to be of no help. It seems "Full Pixel" choice in Display Settings is not available for all resolutions or all inputs, but at least one source says it does show up on one Sony TV for 1080p using HDMI: hometheatermag.com/lcds/907sonybrav/index4.html –  Herbert Sitz May 28 '10 at 15:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.