Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I went to Disk Management in Windows Vista and right clicked the C: drive to shrink it.

It started the process but after a long time had passed, I got an 'Access denied' error. I tried a couple of times, but always have the same result.

How can I fix this problem?

share|improve this question
up vote 1 down vote accepted

I would first run chkdsk on the partition you are trying to shrink and then try to use the disk management tool again. If that does not work, try booting GParted and shrinking the partition from there.

Edit: if you end up using the GParted live cd, make sure not to shrink your windows partition from the front. The front of the partition (to the left in GParted) must remain untouched in order for windows to continue to boot properly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.