Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm working on a Dell Dimension 4700 desktop for a friend. It came with 512MB of DDR2 RAM (two sticks of 256MB). One morning, it started blue screening on startup with no helpful error messages. It refused to boot into any form of Windows installation, including Safe Mode, original recovery disk, and my custom Windows PE disk. It did boot into the Ultimate Boot CD, so I ran memtest86, which reported errors everywhere. I removed one stick of RAM and the system booted up just fine.

I moved the remaining stick into each slot and the system continued to operate normally, so I came to the conclusion that the stick that I removed was dead. I ordered an exact replacement, along with 2 more sticks of 256MB DDR2 (again, exactly the same as the original), bringing the total system memory to 1GB. Upon installing the three brand new sticks, the system blue screened again, this time stating that win32k.sys attempted to write to read-only memory. I inserted my custom Windows PE disk in order to get a better look at the memory dump with BlueScreenView, but it refused to boot and produced another blue screen, but without an error message.

I removed each new stick one-by-one, restarting each time. It continued to blue screen until I was left with only the original stick. I then tried inserting the new sticks in various different orders, but this only produced more blue screens. I reinserted all three sticks (along with the original) and ran memtest86 again, which reported errors all over the place. So, now I'm right back where I started.

I don't think it could be the slots themselves, because I can plug the original stick into any slot and it works just fine. System setup reports each stick correctly and shows the total as 1GB, however. It just seems strange to me that all three brand new sticks of RAM could be dead on arrival.

Is there something I missed? Or should I just go ahead and RMA them?

EDIT: A little more about the blue screens. When I insert all 4 sticks, I get the win32k.sys error I mentioned above. If I use any other combination that includes one of the new sticks, I get one of: BAD_POOL_HEADER, PAGE_FAULT_IN_NONPAGED_AREA, or MEMORY_MANAGEMENT. There doesn't seem to be a pattern to the messages that corresponds to the order in which the sticks are inserted.

share|improve this question
This certainly isn't a complete answer, but I looked up the documentation for that computer online, and apparently you must "Be sure to install a single memory module in DIMM connector 1, the connector closest to the processor, before you install modules in the other connectors."… – Emory Bell May 28 '10 at 23:23
Yeah, the original stick is in slot 1. – David Brown May 28 '10 at 23:55
up vote 2 down vote accepted

It's entirely possible that the DIMMs are defective even if they're brand-new. To find out for sure which sticks are bad, you need to test them individually. Install just 1 DIMM at a time and Boot from your Memtest86+ CD. As you already know, if there are any problems, it will display a list of errors.

It could be the case that the DIMMs' timings do not match the specs they report to the motherboard. Sometimes underclocking them can help, if you don't want to go through the hassle of sending them back. I had a problem with cheap G.Skill RAM not even POSTing when I ran it at the default clock speed, but when I manually set a lower speed in the BIOS, they worked fine. If you do this, be sure to rerun MemTest86+ on each DIMM again.

share|improve this answer
I feel silly for not testing them individually in the first place. One of them turned out to be functional. I guess I just mixed up which sticks I had tested in a group and which I hadn't. I've submitted an RMA request for the 2 defective sticks. Thanks for the help. :) – David Brown May 29 '10 at 1:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.