Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm currently trying to get a windows compiled program to work through Wine to run on Linux and MacOSX.

When I run the program through wine, it prompts me to install Gecko which I do. Later on in the program, it attempts to use MSHTML to render HTML but I get these error messages on my console instead.

err:mshtml:init_xpcom NS_InitXPCOM2 failed: 80004005 err:mshtml:HTMLDocument_Create Failed to init Gecko, returning CLASS_E_CLASSNOTAVAILABLE fixme:ole:CoCreateInstance no instance created for interface {00000000-0000-0000-c000-000000000046} of class {25336920-03f9-11cf-8fd0-00aa00686f13}, hres is 0x80040111

I'm using Wine 1.1.34 and a similar bug was supposedly fixed in 1.1.33
http://bugs.winehq.org/show_bug.cgi?id=12578

I've been at this all afternoon, is there anything I'm missing?

Thanks, Nick

share|improve this question
    
Essentially you are running an app in Wine, and it isn't working as expected. The errors you have are related to Gecko not being able to find the class HTMLDocument_Create. This is odd because this will work under windows. There is a solution to this, I just don't know it. –  Daisetsu May 29 '10 at 0:12
    
-Wine_Gecko is installed at $WINEPREFIX/drive_c/windows/system32/gecko/1.0.0 -My program also contains a web browser which seems to work fine rendering HTML –  Nick Jun 1 '10 at 18:46
add comment

3 Answers

up vote 0 down vote accepted
+100

Even with winetricks wine doesn't support com so creating the com component will cause this error. There is no fix.

share|improve this answer
    
I guess that makes sense, I did a bit more research into the subject myself and I came to the same conclusion, I just forgot I had posted here. I'll re-write it to avoid that specific com object. –  Nick Jun 8 '10 at 7:07
add comment

So if you type "wine iexplore.exe" does it open up the wine version of internet explorer (gecko)?

You said this program was "windows compiled". Are you the one that compiled it? Did you use visual studio?

If this is a .NET application, you'll need to use mono to run it.

http://www.mono-project.com/Main_Page

share|improve this answer
    
-yes, it opens IE with gecko -I meant to say installed instead of compiled -no, its not .net –  Nick Jun 3 '10 at 15:29
    
So your trying to run a program that was installed in windows from linux? Have you tried installing the application in linux using wine? Who knows what dll's and registry keys your missing if you did not install it under wine. Can you tell us what program it is your trying to run? –  James T Jun 6 '10 at 20:20
add comment

Try winetricks.

Follow these steps:

wget http://www.kegel.com/wine/winetricks
chmod a+x winetricks
env WINEPREFIX=yourwineprefix ./winetricks gecko

winetricks is my favorite wine tool and allows you to fix large array of problems.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.